Having problems with your 2000 Ford Explorer ?

2000 ford explorer 4.0 x-engine is stalling, missing and lose power while driving

\015 Ford explorer 4.0 x- engine is stalling, missing and lose powere while driving on highway...replace IAC, MAP, crank sensor, spark plugs and wires, ignition coil, TPS, fuel filter, air filter and DPF and EGR...could it be possible that the PCM is failing, fuel regulator is going bad or the cam sensor is bad.\015\012Help me please...\015 Posted / edited by AnonymousUser on : 15-10-2018

Answers :

I personally would check the fuel pressure. Then I would go back to the coil. I have seen brand new bad coils out of the box. The symptoms of a loss of power point to this component, especially if the car idles well, but loses power when accelerating. Please do not rate this reply - we all are left to grasp at straws since you have changed pretty much everything. Good Luck. Please post the final fix of the problem.
Check fuel injectors, if OK, then probably your PCM
Repair Help & Product Troubleshooting for 2000 Ford Explorer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0052 seconds