Having problems with your 2005 Chevrolet Impala ?

After stopping the car shifts hard form 1st and 2nd gear. service traction light comes on from time to time along with abs lamp. Last time the dealership mentioned that the solenoid was going bad and that was at only 60,000 miles currently im at 92000. Also my engine temp needle is flipped 180 to the other side ( I was told before it may be the cluster).

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for 2005 Chevrolet Impala

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

After stopping the car shifts hard form 1st and 2nd gear. service traction light comes on from time to time along with abs lamp. Last time the dealership mentioned that the solenoid was going bad and that was at only 60,000 miles currently im at 92000. Also my engine temp needle is flipped 180 to the other side ( I was told before it may be the cluster).


... 2005 Chevrolet Impala

1994 Buick Roadmaster LT1 Corvette engine, problems with service engine light coming on, also engine cuts out when cold and after running quite a while, have changed fuel filters numerous times, changed EGR valve,had the memory cleared of cold temp stuff, checked the power box wire, If going down the highway and engine is jerky and tries to cut out, just floorboard it for a few miles and is good for a while and then does it again 10-15 miles later, repeat, repeat. Engine service light comes on w


Same symptoms i had but my solution was very elusive and therefore costly----the main connection of electricity from the battery to the machinery was stripped and would not come completely off but would lose contact for a few seconds at a time interm ... 1994 Buick Roadmaster

Similair to kingdavidps prob except the truck sat with a new motor for 4 years and the gas didnt smell bad,and it started and passed emitions and inspection with that gas in it.drove it 300 miles and the engine lite came on and went off a few times but ran the same.put 20 gallons of good gas in it and drove while noticing it ran better. 65 miles later while noticing the engine lite coming on and going off and no difference in performance,parked and left it running for five min and came back and


Could be your fuel filter gummed up from the old gas ... 2003 Volkswagen Golf

My 2002 Camry (4 cylinder) misfires once engine is hot - after 15-25 miles driving. Checked 4+ days in detail & serviced 2 times by Toyota Dealer - throttle block cleaned, gas filters cleaned, injectors checked and rotated, new spark plugs, !00+ miles of test drives, hours on computers in shop and while driving. Very bad misfire between 60 and 70 mph. I notice when accelerating from 70 to 80+ no misfire. Correlates , roughly , with air and engine temp - runs well when cool. Bucks like a wild h


HiDid the dealer check the crakshaft sensor? it sounds like the timing is shifting causing the misfire.the heat can cause intermitent faults maybe not long enough for the computer to register the fault with a code.And as ... 2002 Toyota 4Runner

2001 ford escape- cooling fan on high even though engine temp is normal I took it to my mechanic and he said the engine temp is normal 220 degrees, and that the fan should be on. I have driven this vehicle for 9 yrs and I have never heard the fan come on in normal traffic. I understand that it is variable. Could a relay or the termostate be going? I am sure that the fan is on at times, but it is on after only a few miles and goes on and off every few mins.and is very noticable.


Check your fan! I think it is the culprit carbon brush usually wear and can't drive your fan to run at low. ... 2004 Ford Escape

My 05 equinox keeps over heating. We replaced the thermostat. The car will run then the temp gauge goes up. When I drive it the temp gauge goes up then after driving like 2 miles it goes down then back up again and stays redlined. At that time the check engine light goes on and the temp light goes on. What's going on?


Ours started doing that last year. Turned out its a very common problem with them. The head gasket blew out. Spent $2200 to have it fixed. Worked fine ever since. ... 2005 Chevrolet Equinox

~70K miles. Timing chain tensioner assembly going bad - I'm told. LOt of noise when starting a cold engine. Noise goes away when engine warm. Sounds like driving with a timebomb in the engine. Any experience with this problem? HOw long can I drive before fixing?


The tensioner going out at or above 50k is a very common problem. The longer you drive without replacing it, the more you risk being stranded with a dead battery or, even worse, a broken belt. Get it taken care of as soon as possible. ... 2000 Lincoln Continental

We have a 2001 Kia Optima. The check engine light came on, the car started losing power while driving and then quit running. The timing belt was going bad. We had it replaced. That did not solve the problem. We had the fuel pump replaced and the cam shaft sensor. Still had the same problem. We can drive it for about 25 miles and the problem starts again. We let it sit for 10 minutes and we can drive another 20 miles before it happens again. When it loses power, it feels like it's down shifting.


You need to find out the error codes being generated when the light came on. These codes will stay in memory until being reset by a code reader. The reader plugs into the OBD II port under the dash, near the steering wheel. (OBD stands for On Board D ... 2003 Kia Optima

I have a 1968 mustang with 1966 289 c. code .engine starts good .idels ,good till it reaches running temp. then it sounds like the rockers start to chatter .and mis fires till it dies.it has 40psi on oil gage while its cold . but drops to 0 psi when it warm .im guessing the oil pump is bad . and causing the bearings to get hot and binding the engine. if some one could help me it would be great. thanks for your time.


Yes.sounds like the oil pump is laying down when oil gets hot,,,,,,but,,,,i would try changing oil filter..I have seen Oil filters will **** together after a few min. of run time.....I would never use a WIX oil filter,,have had 3 friends loose engine ... 1966 Ford Mustang

Transmission Problem? I Have an automatic 2001 Pontiac Sunfire with more than 150,000 miles. Last year going to a party I forced the engine driving uphill. In my way back star doing the shift between gears really rough, I stop the car and few minutes later the car was driving just fine. Since then, and some times not always, when I star driving it takes longer than usual the shift from first to second gear, and the arrow in the miles it dosen't move at all, it stays on 0 until the RPM goes up to


The cheapest and best way to approach this problem is 1st to have the transmission fluid and filter replaced, trans fluid wears out an filters plug with debris from norman trans clutch wear, this service could cure your problem, also mak ... 2001 Pontiac Sunfire

We have a 2001 Kia Optima. The check engine light came on, the car started losing power while driving and then quit running. The timing belt was going bad. We had it replaced. That did not solve the problem. We had the fuel pump replaced and the cam shaft sensor. Still had the same problem. We can drive it for about 25 miles and the problem starts again. We let it sit for 10 minutes and we can drive another 20 miles before it happens again. When it loses power, it feels like it's down shifting.


Try to replace the ignition coil. Defective ignition coil will stop to function when it gets hot. When it cools down, it will function again. ... 2003 Kia Optima

I recently purchased a 2003 Subaru Legacy with 101,000, automatic transmission. The car had the head gaskets, timing and water pump done around 100,000 miles. I noticed last night that the engine temp gauge was a little past the 3rd line towards but not near the red. I shut the heater off and the temp dropped, but after turning it back on the temperature climbed again. Any suggestions to what's going on? This is my first Subaru, I've heard about the stories and that's why I had everything done b


Usually, if you shut the heater off, then the temperature will climb. The interior heater will actually assist in cooling the engine's coolant.Subaru head gaskets rarely ever fail by the way.First, pressure test the cooling system and make su ... Cars & Trucks

1999 Chrysler Concorde LXI 3.2 L engine 68K miles: check engine light came on. Began having transmission shift problems. When cold, shifted ok for first couple of shifts. When warm, won't go into high gear most of the time. Also hard downshifting. Got the following error codes:P0700 (Transaxle control system fault -- failure of transmission control module, TCM, shorted or open ckt within transaxle); P0701 (PCM has determined that the transmission control system is out of range for the current en


This sounds as if the input and output speed sensors may be having an issue. If you are putting a used tcm in it will have been powered down and basically reset to it's defaults.Would completely disconnect the battery and hold the cable ends together ... 2001 Chrysler Town & Country

Rebuilt my 454 engine, installed distributor with rotor at 0 TDC on #1 cylinder. Engine ran fine but ses light was on. Code was P1345-- disagreement between cam sensor and crank sensor. Scanner showed anywhere from 19 to 25 degrees advanced. Rotated dist. shaft. to ****** timing. Wouldn't run. Tried two teeth positions in either direction from original setting. Ever have a sensor go bad. The crank sensor is new, cam (on distributor) is not.


The ignition timing is not adjusted with a timing light or with the engine running, and to set the ignition timing follow these procedures.There is a mark or notch on the distributor housing that the rotor should be pointing to when the e ... 1998 Chevrolet K2500

Clacking valves I've got a '93 rodeo, 3.2, manual trans., 229000 miles, 2 wheel drive. When started the valves go nuts. Loud clacking. When engine is cold as well as operating temp. Not all valves all the time, but one or more all the time. Good even oil flow over all parts and no real wear on cam lobes. Oil pressure is above 35 lbs. at or above 2000 rpm. All bolts under the covers are at torque spec. What's causing the valves to make so much clatter?


... 1993 Isuzu Rodeo

Have a 2002 Honda Civic HX that when idling the heat stops working and the engine begins to overheat, when revving the engine heat kicks in and temp goes down. Intermittent problem, will go hundreds of miles with no problem. Extreme cold seems to trigger the problem. Have replaced thermostat, radiator, timing belt, and water pump, system flushed. Do need o2 sensors replaced.


I would check o2 sensors but to tell you the truth my dad bought a new thermostat that was suppose to open at 160 degrees his temp. got to 220 degrees before but check o2 senors and thermostat ... 2002 Honda Civic

95 contour 220.000k 4cyl 5 spd temp gauge goes over half and check engine light goes on almost instant but i still drive and temp goes down for a bit and light goes out only when i turn engine off and start drivng and temp goes up and down while driving and notice fans running almost all the time and light comes on again until i stop engine running the car still runs good no lack of power coolant level is good and condition not bad . some times the engine seams to sputer when driving for awhile


Coolant sensor may be the problem. It is located near the thermostat housing. It may be sticking between modes & not operating properly.Also make sure coolant is circulating in system. ... 1995 Ford Contour

2008 Avalon: Sometimes won't start. Takes up to 45 minutes of trying before it starts. Will start fine an undetermined number of starts. Had it in three times. 1: Changed starter. 2: changed signalreciever at push button. 3: changed actuator at direction of toyota engineer. Going in for #4 this PM if car starts. Jay Holder @ Florence Toyota in Florence SC knows the problem as it would not start for him. We have an extended warentee. Car is currently at around 80,000 miles.


... 2008 Toyota Avalon

1994 ford ranger 4x4 4,0 it idles good but when going down road the check engine light comes on within 20 seconds acts like it is flooding out loses power let off for a second and then runs good for couple mile but at any time if you put throttle to floor within lastinch or so same reaction any ideas


It should have a code stored. Some places still carry the scanners for OBD 1 Fords for around fifty bucks. Without knowing anything else about the truck or what codes you have, it sounds like you have a bad throttle position sensor. ... 1994 Ford Ranger Supercab

Code 0449 on my 06 colorado, check engine light is on. does the part usually go bad at 60k miles? thanks for your time.


Not usually but can happen at any time being it is electrical. some times they fail because of the few people want to over fill there tank instead of stopping when pump does. part is about 30.00 about 10 minutes to change and is on the vapor canister ... Chevrolet Colorado

My daughter has a 2001 Ford Focus with 79,000 miles on it. Last fall (during warm weather) she experienced power loss at times. The car would suddenly lose power at highway speed. It would idle fine if she pulled over but would not power back to highway speed unless she shut off the key waited a few seconds and restarted the engine. After the weather getting cold last fall, the problem seemed to go away. Yesterday, it returned and the temps outside were again in the low 80's. The symptoms were i


Ford had a recall/ extended coverage on the fuel pumps in the focus vehicles. Do you know if this was done? If not call a ford dealer with your Vehicle identification number (located in drivers door jam or on registration) and they can let you know i ... 2001 Ford Focus

Please excuse me if i sound like i dont know much about cars, cause i dont. So i have a 1997, Jetta GLS 4 speed automatic 2.0 engine with 125,000 miles on it. While driving it the other day the Speedometer, Temp, gas, and Tach gauges stopped working, all pegging at 0 and staying. Since we have bought this Jetta the cruise control has never worked, as well as the red airbag light has flickered off and on and random times. Now we have to fix this problem with the meters. The lights still work, and


I would get a cluster from the junkyard and replace yourself. the back window motors are dead and need to be replaced. I hope this help you. ... 1996 Volkswagen Jetta

My 1997 Saturn SW2 overheated a few weeks ago due to over-reving. Engine temp was bouncing up and down after that. I figured the thermostat went bad as the car has 200k miles on it. Now the coolant level light flashes most of the time the car is running. The overflow tank has adequate coolant. What is most likely the problem?


... 1997 Saturn SL

2005 Sprinter with 140,000 mile has a whining noise coming from the surpitine belt. My tech replaced the tentioner and idler pullys, and fan clutch and belt, noise is still there. The noise comes and go's its not all the time. If you remove the belt the noise its gone. It is coming from the belt. Could the alternator be bad. Or other ideas. Know engine lights are on. The noise seems to come from the alternator side.


If you have a whining noise the first thing I woud check is the alternator. If that is good then I would then check the water pump. I have seen this before but it is hard to point the problem without having the car in front of me.\015\012 ... Dodge Sprinter

I have a Pontiac Grand Prix GT 2001 automatic and currently has 88000K . It has been well maintained, but few months ago noticed after driving it for about 45 minutes in city, when temp indicates around 88-90 degree, then the shifting is with ****. this happens mainly and noticably when speed is between 0-60k and the engine noise is different it is as if something "wii...kind of noise". once I stop for 10 minutes it would go awawy and may re-appear. I can feel that also the car is loosing po


Check all vacuum hoses, electrical connections ... Pontiac Grand Prix
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.5078 seconds