Having problems with your 2006 Saturn ION ?

I have a 2006 Saturn Ion 2. My check engine light is on whit codes P0171 and P0106. My car is running rough, and likes to stall at lights, stop signs, traffic jams etc. (anytime it's idling). There is an audible hissing sound coming from the engine, leading me to believe that there is a vacuum leak. I can not find a leak and I don't have any money to take this to the dealer or a shop. Anyone know alikely spot to check for a vacuum leak?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Remove the housing that covers the engine block and look behind the engine block, up against the firewall towards the bottom of the block there are some vaccum hoses(this is easier to get too if the car is up in the air, or lifted on jack stands) get yourself a aerosall can of brake cleaner and lightly spay around all the hoses til you find your leak( the vehicle must be running) be very careful cause the fluid you spray can catch fire if it hits the exhaust manifold when it gets hot. good luck
Repair Help & Product Troubleshooting for 2006 Saturn ION

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 2006 Saturn Ion 2. My check engine light is on whit codes P0171 and P0106. My car is running rough, and likes to stall at lights, stop signs, traffic jams etc. (anytime it's idling). There is an audible hissing sound coming from the engine, leading me to believe that there is a vacuum leak. I can not find a leak and I don't have any money to take this to the dealer or a shop. Anyone know alikely spot to check for a vacuum leak?


Remove the housing that covers the engine block and look behind the engine block, up against the firewall towards the bottom of the block there are some vaccum hoses(this is easier to get too if the car is up in the air, or lifted on jack stands) get ... 2006 Saturn ION

I have a 1997 monte carlo and i recently cleaned my throttle body and egr ports as well as put new gaskets on them. now when i start it up i have a high idle. changed my throttle position sensor because i had the check engine code and still high idle. also it sounds like a vacuum leak when the engine is on but i've check all vacuum line for cracks but they're ok or unless there is one i can't see or find i don't know. i can really use some kind of help. last thing/ do i have to get my engine com


\012The Idle Air Control (IAC) valve is an electrical component and must not be soaked in any liquid cleaner or solvent. Otherwise damage could result.\012The IAC valve for this application is thread-mount ... 1997 Chevrolet Monte Carlo

1991 Ford E-250 5.8L problem. Deep sucking sound from throttle intake. TPS replaced. Throttle gasket replaced vacuum hoses appear o.k. checked all throttle hoses. o.k. engine runs o.k. no computer codes. when engine revs increase, noise is less noticeable. Sound too deep to come from a 1/4 inch hose leak. Where to look next?


Did you replaced the manifold gasket?  If yes then the only thing left to check is the filter case and its pipe. But a deep sucking sound that weakens with the revs is what you should expect from an engine that sucks air thru a controlling valve ... Ford E-250

I believe I have a vacuum leak on a 1997 Chevy Monte Carlo 3.4 engine and I need to know where I can find a vacuum diagram so I can check all of the vacuum hoses, sensors etc. Does anyone know where I can get a copy on line and print it our?


Chevy dealer / Auto Zone may have one / Repair manual. ... 1997 Chevrolet Monte Carlo

I have a 99 jeep Cherokee 4.0 2wd and it's running rich, missing, and popping. The SUV runs fine then I loose power get a pop then I get power again check engine light is on and the code says a rear o2 sensor is out, The engine makes the air intake sound like a vacuum cleaner at times what is a solution to correct problem. My jeep has 144k miles, the engine is extremely clean, no leaks, and always maintenance d. please help


Follow the code, Replace the rear o2 sensor ... 1997 Jeep Grand Cherokee

I installed a Crutchfield radio in September of 2007, in my 2006 Chevy Trailblazer with the small V-6 engine. During November 2008 my emission lite come on and has continually stayed on. I checked it with a meter from a parts supply house and it gave me a code indicating the engine was running lean which sounds like to me it's vacuum leak in the fuel system. I later found out that my Blazer was still under factory for a emissin problem. (had 29,347 miles on it when I took it in) The SUV has


I had the same issue. Not with a radio but another problem. I was still under warranty and went to the dealership 3 different times and the problem was supposedly fixed the 3rd time but shortly after it had the same problem and of course my warrant ... 2002 Chevrolet Blazer

Have 97 Ford T bird. I sprayed with a power washer not thinking and since the pcv rattled. I took it out and replaced. Check engine is flashing and missed @1500-2000 rpm and I think it sounds like an exhaust leak now as well. Could i have done something to the intake? I know it was stupid to use that hose, senior moment. I think I knocked something lose and have a vacuum leak??? Thanks Don


More and likely water has gotten drowned out one of you coils . this was a problem for ford with water getting around the boots and killing the coil. you can have you check engine light scan at a advance or autozone for free. it should come up with ... 1999 Ford Expedition

2000 Jetta VR6 temperature gauge sometimes dips down to zero or fluctuates while driving. I've checked the coolant levels and for leaks on the driveway/engine compartment and I can't see any signs of a coolant leak so I'm pretty confident that the car isn't overheating. Although when I turn the engine off I sometimes hear a wheezing/gurgling sound immediately after shut down which leads me to believe that water (steam?) is escaping somewhere. This last for about a minute or so then quits.


Remove radiator cap on resevoir and remove hose on the side hold hose over bottle have someone start the car hold rpm at 3000 if coolant isnr rushing out of the hose the water pump is bad if coolant flows the temp sensor is bad ... 2000 Volkswagen Jetta TDI

2002 Chevy Tracker 4wd 2.0 has a whistling sound coming from belt area? Belt is ok, all pulleys working, no engine light on... Been told it could be an idle pulley, vacuum hose leak, resonation from intake manifold... all kinds of things. Any good way to check for sure before we start buying random parts?


Try removeing the serpent belt ...take idler pulley...if it lose in any way ..before doing all this just listen to the front of it ...look care fully at idler ...if it looks kind of cocky in any way change it ...check your belt too ...and all fluid l ... 2002 Chevrolet Tracker

Poor mileage, white smoke, running warmer than usual, motor sounds louder never heard it before, running bad, thinking 02 sensor, not sure if I have all the symptoms, had it checked saids vacuum leaks P0040 i believe P0041 I think my memory serves me right, that is correct lol also it relates to anything of the exhaust system, dont want to change everything out for one not good part


I would check the restiance and the ohms loads on the o2 sensors hope this helps ... 2002 Dodge Durango

Our Mazda MPV 2003 vans check engine light came on so we took it into the shop. They just called and said they needed to run further diagnostics on it, but they believe it has a vacuum leak and oil leack. I don't know much about vehicles and don't want to get screwed over. Any ideas what kind of charges we could be looking at? He'll be calling us back in about an hour with an estimate...


If your mechanic diagnose the vehicle ask for a print out of the results so you can see whats the real problem if the check engine light was on that means that a sensor is giving some kind of problem ... 2003 Mazda MPV

2003 Impala with 3.8L engine idles OK, but looses power when accelerating. Also fails to shift properly. No vacuum leaks (plenty of neg pressue). Disconnecting MAP sensor (unplugging wire) has no effect on operation (same symptoms). Output pin appears to be open-circuit when checked with ohmmeter. Does this sound like failed map sensor? Also, any comments on how to test? Thanks!


Catalytic converters ... 2003 Chevrolet Impala

Intermitant problem with the speedometer not working then working. Check engine light comes on then the next time you drive it does not. Put in new plugs and replaced pcv valve. Sometimes stalls when idleing. Rough idle. Sounds like a air vacuum leak when you accellerate. And it has no power. Car has about 85k in mileage.


Hi,As the Check Engine Light is On, this could be a Combination of problems. I would suggest you to get the Car Scanned next time when the Engine Light is ON and get the Error Code.http://www.fixya.com/cars/r4008552-check_engi ... Ford Focus

Three codes p1670,p0171,andp0174 . p1670 main computer cannot find the a.b.s. computer. I do not think this code alone would bring the check engine light on. But p0171 and p0174 which are engine too lean bank 1 and bank 2 will bring the check engine light on. Took to dealer three times: 1st time they said they found a leaking vacuum canister and two vacuum hoses. It cost me $87. Same codes came back. 2nd time they said fuel pump was insufficient flow. They replaced fuel pump under warranty. Same


Did you or someone in your family TOP OFF the gas tank?\015\012\015\012It's a bad habit that's hard to break.\015\012\015\012====\015\012\015\012The vacuum canister can be soak with gasoline.\015\012\015\012The only inexpensiv ... 2004 Suzuki Verona

2000 mustang v6 has p0174 code. no leaks from hoses or anything external (vacuum) exhaust has no leaks. car runs bad uphill $ shudders from stopping at stop sign and accellarating. p0174 indicates bank 2 is lean (driver's side?) but no other codes present. check engine lite is constant. smoke comes from exhaust when I acellarate from idle when engine is warm. Again, I find no external vacuum leaks from all hoses and solenoids and egr valve.


Hi, have you checked for intake manifold gasket leaks? Pretty common on Ford V-6. With engine running, spray carb cleaner on the gaskets. If the engine speed changes, you have a gasket leak (yes, driver's side of the manifold).\015\012Thanks ... Ford Mustang

Hi , I have a 99 passat 2.8 v6 5 speed , car runs good but my check engine light is on I had it ran and my code that popped up was p 0102 which is mass air flow or massive vacuum leak. I checked for a leak and nothing so I replaced my maf and my check engine light is still on and I have driven it 400 miles so far since I have replaced it . Does anyone know how to reset it so I can get it to pass inspection ??


... 1999 Volkswagen Passat

2001 Ford Escape runs rough on acceleration and at 50 mph runs pretty rough. Once speed is over 55 mph, engine starts to smooth out. Engine diagnostic test indicates excessive egr flow (blocked the vacuum line to egr valve and it didn't affect the running) and a miss now and then on cyl #4. Replaced all the plugs, changed the fuel filter. Air filter is good. No leaks around the intake manifold. Checked for vacuum leaks on hoses, none found. Crusing down the highway with OBD hooked up does


Escape 2001 runs rough, but after a certain speed ( 50 mph ) runs smooth. ... 2001 Ford Escape

My 2001 Ford Expedition started making a clicking/knocking sound from the 5.4L engine, u can really only hear on driver side. I have never had any oil problems, no oil leaks, etc. I checked for any loose items...nothing found. When the vehicle is driven the sound gets a little louder when accelerating. I suspect that a rod may be bad but the engine runs great, good power still, etc. The vehicle has 134K miles on it. Are there any checks I can perform to determine what may be the problem? It does


If it's awd check front driveshaft, I have a 01 awd an had the same thing when I give it gas knocking get loud, I removed the front drive shaft an the sound is gone an my mpg has went from 10 mph to 17 mph, their Is a bearing on the trains, that goes ... 2001 Ford Expedition

My 2001 Ford Expedition started making a clicking/knocking sound from the 5.4L engine compartment. I have never had any oil problems, no oil leaks, etc. I checked for any loose items...nothing found. When the vehicle is driven the sound gets louder when accelerating. I suspect that a rod may be bad but the engine runs great, good power still, etc. The vehicle has 104K miles on it. Are there any checks I can perform to determine what may be the problem? It doesn't make sense that the rod/rods may


... 2001 Ford Expedition

Check engine light just cam on. got it checked at autozone they said it might be leak in evap system,evap canister broke, purge or vent solenoide defective, or vacuum leak at engine. i dont know which 1 it is and how much its going to cost me.


The diagnostic code that relates to those causes are all from the emissions system and won't necessarily effect your vehicle performance, reliability, or it may still well be able to pass an emissions test.The most likely of causes would be any ... 2006 Volkswagen Jetta

I have a1996 F150 with a 5.0 engine. I have the peoblem when climbing or loading my engine my air conditioner blows out the defrost register. When I unload the engine the AC returns to the vent output. I found the white vacuum line on top of the blower motor decomposing and I replaced it. This helped a lot but the problem still happens if I load the motor a lot. I am also getting an EGR air flow code error. I have checked vacuum lines under dash and under hood and can not find vacuum leak. Pleas


This is caused by a loss of vacuum to the AC control head from the engine vacuum storage canister, the line comes through the engine firewall on the passenger side under the dash, remove the kick panel, then unplug the vacuum harness (the lines are p ... Ford F-150

2002 2.4l santa fe accelerating uphill and check engine light came on. Instant loss of power with loud knocking sound. Engine idles smooth with no knocking but when increasing rpm's the knocking also increases with a decrease in power. Check engine code was PO300 multi-cyclinder mis-fire. Have replaced both coils, wires and plugs. Still knocks very hard and still no power. Checked timing marks, two top marks lined up. Performed leak down test, seemed fine. Timing Belt and tensioner installed D


You should do a compression check to make sure the cylinder walls are good then check the crank position sensor. If the Timing is good and the timing belt is good but your getting misfires on coil packs it's time the check the crank position sensor. ... Hyundai Santa Fe

Misfire/boggin down/shaking I recently changed my air filter and after doing this have had a lot of problems..I have gotten the check engine light for the first time ever and checked the code and it says to check the following: large vacuum leak ignition system malfunctioning mass airflow sensor faulty or needs cleaning air/fuel ratio set bad I have cleaned the mass air sensor/throttle body/intake and checked the coil packs/wires..is it possibe I've pulled off a vacuum hose from simply taking of


If you cleaned the mass air flow sensor (MAF) and your still getiing the problem. You may have to replace it. But before you go there. Strat the car and listen for a lond hissing sound by the throttle body area. If you hear it you have find it .You c ... 2000 Toyota Sienna

Need a diagram of the vacuum system for a 2003 windstar. Have a vacuum leak and believe it is near the blend door. Ran a vacuum test and it is definately leaking. The blend door makes a flapping sound. The temperature slides for front and rear AC / Heat do not work. Please help but also please supply a vacuum diagram Thank you ! Shields Fair


... 2003 Ford Windstar

I recently replaced my injector because my car was having issues that I believed were fuel related which I still believe is the case. My next course of action is to check for vacuum leaks can anyone


What was the resistance of the injector you replaced injectors dont really just go bad all they are is a coil with a magnetic like plunger or in other words a electro magnet do check for vacuum leaks if you feel its fuel related how about fuel filter ... Cars & Trucks
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 3.1204 seconds