Having problems with your Chevrolet Camaro ?

I'm helping out a friend on a 1996 Camaro and the problem I'm having is when I try to start the car everything turns on lights, dash etc... but when I turn it all the way forward to the start position nothing happens it all goes Blank, the power go out and thier seems to be no power to anything until I put it back to the on position then the lights, radio, power etc... come back on. Can you help? Thank you, Tim

Posted / edited by AnonymousUser on : 15-10-2018

Answers :

Check the connections to the battery,and remove the cables from the battery,negative first,and clean the battery terminals on the battery,and the cable ends,until shiny,then try and start the car,have the battery checked,and once the car is started have the alternator checked.
You have a bad starter cable connection. Clean your battery cables first & try to start the car. If this fails, remove the ground wire at the battery, then go underneath the car & remove the starter cable & clean the connections at the starter. Reassemble in the reverse order. The car should start. If it does not start you may have developed a "flat spot" on the starter, sometimes it takes a sharp tap with a large screwdriver to dislodge a stuck selinoid on the starter. Good luck!
Repair Help & Product Troubleshooting for Chevrolet Camaro

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0053 seconds