Having problems with your Chevrolet Silverado 1500 ?

Rain sensor does not work on 07 Chevy LTZ Silverado. Put on intermitent mode and nothing. Unplug sensor and wipers work fine. Know a solution? Also, Cruise control doesnt work... Are the fuses related?

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

Repair Help & Product Troubleshooting for Chevrolet Silverado 1500

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Rain sensor does not work on 07 Chevy LTZ Silverado. Put on intermitent mode and nothing. Unplug sensor and wipers work fine. Know a solution? Also, Cruise control doesnt work... Are the fuses related?


... Chevrolet Silverado 1500

Stays in first gear at high RPM's Will shift fine when I let off the gas and all other gears shift fine. Trans oil is clean and full. Traction Control off light is on and will only go off when car is in park. Stay off for about 5 minutes after car is put into drive. Cruise control has also stopped working. Everything worked fine a week ago, Checked all fuses and rebooted the ECM by disconnecting the battery. Check engine light on. Code says I need a new oxygen sensor.


... 2000 Pontiac Firebird

My temperature gauge does not work. There is a good amount of heat coming out of the heaters so I know it's not thermostat related. I also checked all of my fuses and there fine. I think the problem may be in one of the modules located with the fuses under the hood but I don't know which one. The vehicle does not have an owners manual for reference. Can you tell me what the cause of the problem may be?


There are two coolant temp sensors one is for the ECM and the other is for the gauge. They should be located near the upper rad hose water outlet. Normally the one for the gauge is a single wire sensor. Disconnect it and turn the key on take a test l ... 1999 Ford Explorer

99 suburban,rear brake lights and turn signals work intermittently. Tail lights are fine on both sides. I have replaced bulbs and the circuit panel on the rear to no avail. I think it may be the turn signal switch itself. I also lose the cruise control whenever i hit a bump, like crossing a bridge, also. Could the ground be the cause of this? Another point of issue that may not be related directly is that my horn fuse blows whenever it is replaced and the driver side door jamb switch works inter


Blinker switch can go bad everything runs through the switch ... 1999 Chevrolet Suburban

Got an electrical issue with my 99 suburban. Back up lights don't work, both sides. I have other electrical issues don't know if they are related. Seat heaters work off and on, front passenger door opening doesn't trigger overhead interior lights. Also, the Turn signal arm...the cruise control works intermittently, the windshield wipers work intermittently. It's not the fuses. Im at a loss. There is a wiring harness for trailering. But it's not hooked up to anything. Looking for help g


My gfs envoy does this stuff too. Weirdly i found a wiring harness under the driver seat that has a mind of its own. When these problems happen look under the driver seat and move the wiring harness around. It fixed my problem, it may be a connect ... Chevrolet Suburban 1500

I have a 2000 chevy silverado 1500 extended cab and the heater went out. It was working fine yesterday now it doesnt at all. On all settings I get no air blowing out (even on a/c setting) of any of my vents but when I put my hand over vent I do feel a little heat so I know it is not the heater coil. I also checked my fuse marked frt hvac in electrical panel and my fuse is good.........any ideas what is wrong and how to fix?


Sorry but your blower motor has went to the graveyard,its not to bad to replace ,but that has what has happened,..... \015\012\015\012Remove the blower motor insulating cover screws. \015\012Disconnec ... 2000 Chevrolet Silverado 1500

Where is horn fuse on a 1993 cadillac eldorado.The horn doesnt work, and also abs sensors light mil is on. Any possible solutions


... 2002 Cadillac Eldorado

I'm having a problem with the dome light and both reading lights. they all stopped working at the same time. I checked the fuses and they look fine. The car is a 2004 Buick Century I don't know if it's related but the door/trunk open light on the dash is also lit. I have checked all of the doors and trunk and they are all closed. Thanks for your help


For your first problem I would suggest taking a test light and double checking the fuses I would always recommend doing that because I have worked on numerous vehicles where the fuses were pulled and not replaced firmly and not making contact (just a ... Buick Century

The jeep wont start. It cranks but it doesnt start and everything is working fine... llike my radio and my lights etc... but it just wont start i have checked all the fuses and i even tried replacing the camshaft position sensor. before it didnt wanna start it was working fine but i was changing some fuses. then after i changed them my car didnt start and a mechanic checked my fuses and said they were fine.


Try the crank position sensor. the one on the bell housing ... 2000 Jeep Grand Cherokee

My 2003 chevy trailblazer ls rpm gage has completly stopped working. when it first started going bad it would work on occasion and now the needle doesnt even move from 0. my car feels and sounds like it is shifting when it should its just the gage that doesnt work. what could cause this? is it a bad sensor, wires or something all my other gages work fine its just the rpm gage. if anyone knows how i can fix this problem please let me know what i need to check i want to be able to fix it myself if


... 1996 Audi A4

My cruise control stopped working many years ago. I want to fix it but don't know how to troubleshoot it. I checked the fuse and it is good. It quit once before and the tech fixed it he said it needed a $2 clip or something. I don't exactly recall. It is a 1997 Subaru Impreza Outback Sport with the 2.2l. It is a manual with dealer added subaru OEM cruise. I am relatively compitent haveing swapped out trannies and motors but I just don't know how the cruise works because I've never tried. Where s


There is a little black or white depending on the brand rubber buttong located on the clutch pedal that just pops out and pops back in. what happens is the pressure ends up putting a dent in the rubber and so it no longer makes proper contact. its is ... 1997 Subaru Impreza

Overheating fan will not run ! I change cooling sensor, fan relay,new radiator, thermostat, fan motor, check all fuses, tank low coolint sensor, put fresh coolant in also. (1998 achieva SL 3100 V6 SFI ) The only time i get fan to run is when i pull connector off cooling sensor. change this sensor twice to be shure. sensor has voltage on it about 5 v bench test fan also works fine. When coolint sensor is disconected the fan will run and keep running until i connect it back to sensor then it shuts


There isa short in the wiring somewhere,which a shop can check for you,or check your thermostat. after 20 years i still have to make sure tat i dont install it upside down. which is easy to do if your in a hurry. my bet is that the wiring going to th ... 1998 Oldsmobile Achieva

I have a 2002 Ford Taurus and the radio just stopped working it was flicking on and off then just went out.There is no clock or nothing and no power.The climate control and everything still works fine. So I replace the cluster for the radio controls still no change I also changed out the radio tuner amp in the truck still nothing. I also checked all fuses and all looked fine none blown. Does anyone out there know where and what I can do now? No radio sucks!


... 2002 Ford Taurus

My cruise control doesnt work on my 1991 GMC Sierra K1500, I have put in a new actuator but it still doesnt work. What I need to know is what fuse runs it, what,if any relays are involved, and if the switch right near the brake light switch is the one to deactivate the cruise control


... 1991 GMC K1500

Cruise control??? I just bought a 2001 impala ls for my wife. When I test drove the car the cruise worked fine, 2 days later I bought the car and on the way home I tried the cruise and it doesnt work. I checked the fuses, the plug on the unit under the hood, and it still dont work.. I am open for suggestions..Thanks


Just pull up the break pedal and that's all!!! ... 2001 Chevrolet Impala

Mercedes benz/2000/clk 430/air pump does not work. pump is operational, but it does not have current. I traced the input source to the fuse box located under the passenger side of the hood. The wire is red with a white tracer. I cannot trace the wire or current source further. I want to know if the relay in this fuse panel is related to the air pump, and is the 40 amp fuse also related to the air pump? There is no current at either side of the 40 amp fuse.


You probably have 3 or 4 relays there. Check the fuse panel cover for what each fuse/relay is or you manual wil detail every slot there.. You will not get any current to the pump until power is on and that is determined by the system stating it nee ... Mercedes-Benz CLK

I have a 2007 chevy colorado that the heater quit working on... its not the usual 1-3 that doesnt work, none of the setting work, also i have checked the fuse, resistor, harness, and the ground on the ps fender... all are ok (not bunt/blown) also my blower motor works just fine if i put power straight to it... so is it the switch that is bad or did i miss something??


\015\012Condition/Concern:\015\012There are possible concerns; Erratic operation of... blower motor, windshield wipers, fog lamps, SIR indicator, cruise control, ABS indicator, battery drain and a pos ... 2004 Chevrolet Colorado

2001 HYANDAI ELENTRA car was stuck in 3rd gear changed turn signal fuse was blown changed fuse work fine for a short time then then fuse blowed again then trans stop shiftinh again i changed the output speed sensor,input speed sensor,range selector,vechile speed sensor.problem was still there unplug the cruise control the car shifted great for a day the it started blowing the turn signal fuse again and stayed in third gear.any ideal whats wrong?


I would suspect you have a short in the wiring to the transmission or the shift solenoid inside the ****** is shorted. Only way to know for sure is to get the wiring diagrams and trace down and inspect all the wiring that the fuse powers. ... 2000 Hyundai Elantra

My 1996 Chrysler Town & Country horn will not work, is there a fuse? I looked under the hood at the main fuse box, but there is no fuse for the horn. Also my cruise control will not work is this related?


If the horn and cruise control isn't working this is a recall. I had the same problem on my Plymouth Voyager and now have a Town and Country ... 1996 Chrysler Town & Country

I HAVE A 1994 OLDS SILHOUETTE AND THE FRONT BLOWER MOTER FOR THE HEAT HAS BEEN ACTING UP SOMETIMES IT WORKS SOMETIMES IT DOESNT AND NOW IT WONT WORK AT ALL BUT THE BACK ONE WORKS JUST FINE I HAVE CHECKED THE FUSE AND THE RELAY AND EVERYTHING SEEMS TO BE FINE ANY SOLUTIONS TO FIX MY PROBLEM


Bad connection right at the blower motor. put the blower motor on and wiggle the two wirer connector. this is the most likely cause and the fix is to bend the prongs to get a tight fit again in the connector. ... 1994 Oldsmobile Silhouette

Me problem is that my 2002 Alero heater controls do not work, But let me clarify what i mean. The knobs that turn for fan speed, hot or cold, and defrost all work fine, but the push buttons below to circulate the air, the a/c button and the rear defrost buttons do not work. So i checked the fuse from under the hood for the htr - A/c and it was blown, so i replaced it with another 10amp fuse and it blew that one also, Now i know there is a short or something someplace. And the other part of th


I SEE 3 THINGS THAT WILL CAUSE FUSE TO BLOW.BAD AC COMPRESSOR CLUTCH RELAY.AC COMPRESSOR CLUTCH COIL SHORTING OUT.OR THE COMPRESSOR DIODE OR WIRE CONNECTOR HAS A SHORT IN IT. ... 2002 Oldsmobile Alero

My 96 LHS has a couple things going on...first the AC only blows warm air (two mechanics say it's NOT the freon)...one says it could be the powertrain control module, another says it's a pressure sensor in the AC (and is stick on 500 lbs of pressure), 2nd thing is the air bag light is on (mech says it's the sensor in the bumper to the tune of $600) and 3rd is the cruise controlwon't work. The horn is working fine...are these things related and can I replace the airbag sensor myself?


If it is not the freon, then it could be the electronics that are supposed to electrically open the valve that lets the freon into the evaporator that gets cold. It is not a pressure sensor, but a valve.But yes, it is easy to replace the ... 1996 Chrysler LHS

The dim headlights work, but the bright beams do not, even though the halogen bulbs are new. The horn and cruise control also do not work. The fuses inside are fine, but I was wondering if there is a relay or a fuse under the hood that could be causing these problems?


U have 2 separate problems here, 1st lets look at the horn and cruise, this is caused by the rotating ribbon contact located under the steering wheel, it is called the CLOCK SPRING contact ribbon, it is defective it has a ... 1998 Ford Windstar

I installed a trailer brake controler on my 2003 silverado 1500hd with the kit that plugs into the factory wiring harness and the trailer brakes worked fine but the brake lights and the cruise control do not work any more. I replaced the brake light switch and I am still having the problem. I also checked all the fueses and they seem to be all fine. I have the controller unplugged now and the same thing is still happening. Any ideas please let me know.


Check 25A fuse under the hood.\015\012Check 15A stop light and 10A turn signal fuse under the dash.\015\012If all fuses check out, verify that the switch is operating the brake lights. ... Chevrolet Silverado 1500HD

Horn on my jeep grand cherokee 1999 does not work neither is the cruise control and other stearing related things .. signals n vipers are working fine .. i thinks its the fuse .?? but cant seem to find the fuse in the box..please help!!


Check under the hood there should be two fuse boxes...the horn and cruise being inop is probably caused by a bad clockspring ... 1996 Jeep Grand Cherokee
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.6551 seconds