Having problems with your Toyota Celica ?

Changed engine in my 93 Celica. Used all of the original sensors on new motor. Engine starts easily and idles very good. no check engine light at idle. If you step on the gas at all, the engine shakes badly and the check engine light flashes in sequence with the shake. If you let off the gas the engine returns to smooth idle and no light.

Posted / edited by AnonymousUser on : 16-04-2018

Answers :

Have you checked to see if the harness on the distributor is plugged up good?How about throttle position sensor?Is it plugged up?Let`s look at the distributor timing,is it in time?If you disconnected the injector harness on each injector,they may have been crossed somewhere.Let me know after you check all the harness connectors also,and make sure they are plugged up good,and all body and engine grounds are bolted down.
Did you put on new timing components because it sounds like the motor is out of time.
Repair Help & Product Troubleshooting for Toyota Celica

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0056 seconds