Having problems with your Volkswagen Golf ?

I have a 2002 Volkswagen Golf with a 2.0 engine. The 'check engine' light starts to blink and the car starts to shake violently, and it doesn't accelerate past about 25km/h. Then after riding it that way for a few minutes, the engline light stops blinking, and just stays on. The car shakes a little bit (not as violent), and the car accelerates past 25km/h but has a hard time doing so. I've taken it to the mechanic and the first time, they replaced the catalytic convereter and the spark plugs.

Posted / edited by AnonymousUser on : 15-01-2018

Answers :

There are a LOT of problems that could have this effect on an engine ... but from this description it sounds like your timing chain might have skipped a tooth. If your timing is off, the pistons will not fire at the correct time, and will cause a violent shake in the engine, and the engine will lose almost all power. This issue would also cause a hard start whenever you try to get your car started, so it may not be this ... \015\012
\015\012You might have a leak in your head gasket which is leaking either water or antifreeze into one of your pistons. When you start the car, is there a sweet smell in the exhaust? If antifreeze gets into a piston, it usually stops that piston from firing at all. This could cause a violent shake in the engine, and might not cause a hard start, so it would only be noticed when you start driving.\015\012
\015\012You could have a dead spot in your distributor cap -- the piece of the engine that distributes electrical charge to the spark plugs. Replacing the plugs is a first step to finding out if it is this problem -- it is cheaper and easier to do than replacing / repairing the distributor cap. When the plugs don't want to fire correctly, it has the same effect on the engine as antifreeze in your engine -- a violent shake and diminished power.\015\012
\015\012There is a SMALL possibility that it could be your transmission. If your transmission is getting stuck in the wrong gear, or between gears, the engine will try to pour out power, but will get so bogged down by the malfunctioning transmission that the whole car will shake. This is a VERY rare problem, but it does occasionally happen.\015\012
\015\012Your car's computer might not be sending or receiving the correct information to or from the engine. If this is the case, it could be pumping a different amount of fuel to each cylinder, causing the engine to fire too hard sometimes, and too soft other times. This would prevent you from getting proper acceleration, and could cause a shake in the car, but I don't think it would be a Violent shake like you described.\015\012
\015\012You could have a bent Cam, which would not allow the valves to function correctly (but this would probably keep the car from starting). It could be a bad bearing in the engine (but this would probably keep the car from starting at all). You could have faulty valves (but once again, it would probably not start at all). There are a lot of other possibilities as well ... but I think you get the point here. It is going to take a while to figure out exactly what is wrong. If you have a friend who is willing to help you out, or a really cheap mechanic that you can take it to, you'll probably save a lot of money over taking it to a corporate shop. Best of luck!
Repair Help & Product Troubleshooting for Volkswagen Golf

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

I have a 2002 Volkswagen Golf with a 2.0 engine. The 'check engine' light starts to blink and the car starts to shake violently, and it doesn't accelerate past about 25km/h. Then after riding it that way for a few minutes, the engline light stops blinking, and just stays on. The car shakes a little bit (not as violent), and the car accelerates past 25km/h but has a hard time doing so. I've taken it to the mechanic and the first time, they replaced the catalytic convereter and the spark plugs.


There are a LOT of problems that could have this effect on an engine ... but from this description it sounds like your timing chain might have skipped a tooth. If your timing is off, the pistons will not fire at the correct time, and will cause a vi ... Volkswagen Golf

2000 mercury cougar v6 engine, automatic transmission. I noticed a few days ago that at night with lights on , lights started to go on and off a little bit, not all the time, and battery light came on, but then the car was normal ,battery light off, till last night that while driving on the freeway at night lights started to dim , and the battery light came on , I drove till the car stopped, when the battery was drained, somebody brought me another battery and thats how i made it home,, I thi


Hi, from the detailed explanation you have gave concerning your car till the time the battery light came on, it seems obvious that the battery is not charging as you have rightly suggested. It's either you have a corroded wire which is not allowing c ... Mercury Cougar

Car will run and then some time later stalls, then starts rught up and then a little bit later stalls, did this 5 times today and finally wouldn't start when the engine got hot (actually just hotter) seems like it stalled sooner as we kept starting it and running it till it stalled. The security light only came on one time. Its the v6 engine with 60K miles, changed fuel filter and that hasn't helped


You have a lot to check. Start by scanning the engine codes. There's good chance it will tell you where to look next.\012\012The symptoms sound like fuel delivery (assuming the engine runs well when it runs). Put a fuel pressure gage on the ... 2002 Oldsmobile Alero

Have a 2002 Mitsubishi Galant 4 cyl. When Car is cold starts fine. Once i run around shut car off will not start.(this does not happen all the time) If i keep trying to start it i can smell gas. then i let it sit for a little bit it will start right up. once this happens the service engine light will go on but in a few hrs sometimes days the light will go off. I have changed the two coils thinking they where bad.. but it is still the same problem .


... 2002 Mitsubishi Galant

Dash board lights on grand voyager flashing when engine on. car would not start so charged bat over night. Then bought a new bat. have changed battery and still happening. Did altinator test lights dipped a bit i think! did this test several times lights stopped flashing. turned engine off and on but lights still flashing. little orange lights for air con back wiper and back washer. also noticed that when now put heating on different controlls can hear a clicking noise coming from dash. never di


The controls always click when you change the setting as it is electronic, don't panic, but you should ask your ex as he is well up in voyager' s and the back seat not folding down properly!!!!! ... 2000 Chrysler Grand Voyager

2004 Sebring 2.7L. The car was running fine with no apparent problems. I turned the car off for a few minutes to get gas. When I went to start the car again, it wouldn't start at all. No clicking, very dim lights. I tried jumping 3 times. It would start, then die. The third time, I revved the engine a bit to try to keep it running. while revving, lights on the dash would flicker and the gauges were jumping a bit. car still died once I stopped revving and tried to drive. The battery has been long


Check for 12 volts at the battery if it is anything less you will need a new battery. ... 2004 Chrysler Sebring

Good day everyone. A couple times when I had tried to start my car I had heard this kind of grinding sound and the car shook a little bit. Trying to get to the bottom of this problem I started my car about 15-17 times or so trying to get it to do it again but it wouldn't and hasnt done it since. I know starting it this many times is a workout on the starter, but could I have hurt the engine by doing this. I really did not consider this before trying to solve my other problem, and it got me a bit


You should be fine. the grinding could have been a bad spot on your flywheel ring gear causing the starter to not fully engage thus making the grinding sound. ... 1998 Toyota Camry

Good day everyone. A couple times when I had tried to start my car I had heard this kind of grinding sound and the car shook a little bit. Trying to get to the bottom of this problem I started my car about 15-17 times or so trying to get it to do it again but it wouldn't and hasnt done it since. I know starting it this many times is a workout on the starter, but could I have hurt the engine by doing this. I really did not consider this before trying to solve my other problem, and it got me a bit


None what so ever, the only thing that you might have a problem with in the future will be the started motor might ware out sooner than normal, and your battery may have took a hammering, but normally they are built to last these days so, apart from ... 2008 Ford Fusion

Good day everyone. A couple times when I had tried to start my car I had heard this kind of grinding sound and the car shook a little bit. Trying to get to the bottom of this problem I started my car about 15-17 times or so trying to get it to do it again but it wouldn't and hasnt done it since. I know starting it this many times is a workout on the starter, but could I have hurt the engine by doing this. I really did not consider this before trying to solve my other problem, and it got me a bit


No you can't hurt the engine by cranking it. the engine is designed to turn over. it just put a load on your battery and starter is all. ... 2001 Chevrolet Suburban

Good day everyone. A couple times when I had tried to start my car I had heard this kind of grinding sound and the car shook a little bit. Trying to get to the bottom of this problem I started my car about 15-17 times or so trying to get it to do it again but it wouldn't and hasnt done it since. I know starting it this many times is a workout on the starter, but could I have hurt the engine by doing this. I really did not consider this before trying to solve my other problem, and it got me a bit


As long as your engin started and pumped oil it should be ok but if your starter is loose or worn gear it could strip teeth on flywheel ... 2002 Ford SVT Focus

Good day everyone. A couple times when I had tried to start my car I had heard this kind of grinding sound and the car shook a little bit. Trying to get to the bottom of this problem I started my car about 15-17 times or so trying to get it to do it again but it wouldn't and hasnt done it since. I know starting it this many times is a workout on the starter, but could I have hurt the engine by doing this. I really did not consider this before trying to solve my other problem, and it got me a bit


No ....under any circumstances people start their vehicles many times during a day especially delivery drivers consider pizza drivers ,ups etc....however if the grinding issue continues again i would 1st consider loose starter bolts ..then proceed fr ... 2005 Nissan Altima

MY FRIENDS CAR IS SHAKING REALLY BAD AND THE ENGINE LIGHT IS ON. SHE TOOK IT TO AUTO ZONE AND THEY SAID ITS A CYLINDER 1 MISFIRE. SHE ALREADY HAD HER FRIEND CHANGE HER SPARK PLUG WIRES AND IT HELPED FOR A LITTLE BIT BUT AFTER LIKE A HALF HOUR OF DRIVING IT STARTED SHAKING AGAIN REALLY BAD AND THE LIGHT CAME BACK ON. WHAT ELSE COULD BE WRONG. DOES IT NEED TO BE RE TIMED OR IS IT AN IGNITION COIL??


It most likely is the coil, but recheck the spark plugs and spark plug wires just in case one of the new wires are touching a hot exhaust manifold.. ... 2005 Kia Optima

Have a 1992 buick lesabre with a new problem. I tried to start the car on Thurs. all lights inside, radio, ac, instrument panel lit up. there was no sound from the engine. I adjusted the gear shift and retried to start the car. It started. On friday the car started first time and then it randomely did this again. only this time it would not restart. We adjusted the gearshift, tried starting in neutral, moving the car a bit, nothing worked until it was ready to start. what's wrong with my car?


The ign lock cylinder has two tiny wires that may be going bad and not making connection. The fix is to replace the ign. lock cylinder and chip key. The starter will not turn over if they are not making contact and it may go into a shutdown mode for ... 1992 Buick LeSabre

I have an isuzu rodeo 2004 3.5l automatic transmission 4x4. i have the check engine keeps light on and off from time to time but it is on almost all the time, if it is off then it will light on after stop the car while it is starting on, or when i stop and keep gear on D for some time then the reduced power will light on as well and the car will not go faster than 30-40 KMH and it does not matter how much i push on gas, after a little time reduced power goes of and car speed up almost normally.


... 2004 Isuzu Rodeo

I have a 2002 Daewoo Nubira 2.0 L engine the check engine light comes on at random this is after the engine misses a slight bit then the light goes out and car runs ok. This has happend about 5 times. Feels like the fuel is dirty or may have water in it. 1 time the engine stopped but started again no trouble. Prior to this problen I let the fuel tank run quite empty. Then I filled it up after 40 or so KM the problem started. Can you Help. Thanks Eldon Peterson


The check engine light is associated with the engine missing.The engine computer has a misfire counter programed in it's software once a certain threshold is reached it will turn on the check engine light. Once ... Daewoo Nubira

I have a 1996 Toyota Camry, with 301,200 miles on it. Just recently I noticed that when I am stopped for a light, the tachometer starts at 1 but then drops down a bit and then comes back up to 1. It feels like the car burps a bit. (The check engine light has been on for quite some time because I know there is the catalytic converter issue. But when the OBD was used this time, it not only said the P0420 code but also the P0755 code. Was able to cancel out the check engine light and it hasn't


Remove and clean idle air control valve. do not put whole valve in any liquid. just clean valve on end, do not push on valve end, or it will mess up idle setting. then clean around throttle plate in throttle body. there may be carbon around plate ... 1997 Toyota Camry

Distributor Problems I replaced the original distributor in my car approx 2 years ago after my car stalled on me. I'm not sure if they used a new one or a refurbished one. It went out again this past August and I replaced it with a refurbished one. At that time, the mechanic noted my relatively new spark plugs were blown also. This past week, my car started cutting off on me and wouldn't start again until some time passed. The check engine light came on and my mechanic said my distribu


Try replacing only the distributer cap as your previous rotor arm was making slight contact when new its probably been the cap contacts all along make sure you identify each lead and cap to plug before you disconnect/reconnect ... 1999 Honda Civic

My 2004 Santa Fe had he check engine light come on several times in the past week. It started to run rough, like it was going to stall, then the check engine light came on. I took it to a mechanic. First, the code was for the wires, which were replaced. Later that day, after it was fixed, it started doing the same thing and the check engine light came on again. Then the mechanic said it was for the engine coils, which were both replaced. 2 days later, the car stalled on me and the check engi


Probably not a glitch but an possible issue with the crankshaft position sensor intermittently losing its signal to fire the coils.The crank sensor should be ohmed out when the vehicle is warmed up and when it is cold just to verify that it stays wit ... 2006 Hyundai Santa Fe

95 contour 220.000k 4cyl 5 spd temp gauge goes over half and check engine light goes on almost instant but i still drive and temp goes down for a bit and light goes out only when i turn engine off and start drivng and temp goes up and down while driving and notice fans running almost all the time and light comes on again until i stop engine running the car still runs good no lack of power coolant level is good and condition not bad . some times the engine seams to sputer when driving for awhile


Coolant sensor may be the problem. It is located near the thermostat housing. It may be sticking between modes & not operating properly.Also make sure coolant is circulating in system. ... 1995 Ford Contour

2000 acura every now and then, car would idle rough when started, yesterday car wouldnt start at all. so i waited and tried again a few times, then i pumped the gas a little to get the rpms up and once i got on the highway it ran much better, but the check engine light came on but didnt flash. put on diagnostics they reset the codes and check engine light went out. what do you think?? they told me it could be the egr valve at the first place. the second place i took it to could not diagnose pro


I have a 2000 TL as well. Had a VERY similar situation. It wasn't a constant problem and ran fine between times just like you said! Frustrating! It wound up being ONE coil that was starting to fail. www.acurazine.com is a wealth of info. ... 2000 Acura TL

Hi,Everyone! To start with ,the other day I had problem with my 2003 Hyundai Santa Fe 2 wd,automatic transmition .I was driving to work and my car was changing the gears a little rough.At one point the rpm starts going up and down all the red lights and check engine light flashed and I managed to pull over at a small plaza ,before my car completely died.I recently changed timing belt ,have about 3000 miles with the new one.At first I tought it has something to do with the timing belt or may be t


If you hillbillied the exhaust at the front manifold, then you are losing pressure and your O2 sensor, [oxygen sensor] won't read properly. This can cause the car to buck and lose power. Also, if the O2 sensor isn't working, it can cause your IAC, ... 2003 Hyundai Santa Fe

I just washed my car i was at the light and the car shut off i have lights radio works and everything it keeps burning one of the 20 amps fuses under the hood with the engine symbol and i have been getting a clicking noise when i try and start my car like the past 3 months or so its clicks a couple of times then it cranks up now it just shut off when i was waiting at the light and it wont start it tries to turn over but it wont turn over all the way need help


Hi Eason, The fuse which keeps blowing is the ECU fuse, which means the computer isn't working. That being so, the vehicle will will not start. The starter motor problem is separate and will need the starter relay or the solenoid replaced. The fact t ... 2001 Chrysler Sebring

2006 Pontiac Torrent. I start the car and it sounds fine, but then the engine just turns off and the check engine light comes on, and the light that looks like an engine with a down arrow comes on. It happens when driving and not driving. The car usually works in the morning and at night but not during the daytime. The first time this happened was a month ago, i waited a little while and turned the car back on and it was fine. But recently it keeps on turning off repeatedly. Everything in the ca


Camshaft sensor is the most likely problem. Here is the location on your model. ... 2006 Pontiac Torrent

Driving normal, at 80 kms, car seems to studder a bit, (gas wise) engine light comes on. Stop car, re-start, everything fine, no engine light, at 60 kms, fine, get up to 80 km, engine light comes on and stays on. Going up hill appears to be weak. Hard to get it up to 80 kms??? Bought vehicle 2 weeks ago, previous owner had done everything at 95,000 km, now at 98,000 km. Land Rover Freelander 2002. I mean everything, new throttle body, new timing belt, new water pump, vehicle was driving beautifu


First try replacing air filter if not done recently $30, next consider bad fuel put in fuel from major oil company from station with many patrons.Then you need to look at fuel delivery system including fuel filter and furl pump. But first try the 2 t ... Land Rover Freelander

I have a 2002 grandam se v4. I drove it earlier today and the car ran perfectly fine. When my buddy started the car later the car was idling real rough and the engine sounded different than usual, little bit of a putter out of the exhaust sound. When the car was revved some, there was also a smell of gas. The service engine light was blinking as well. The Trac off light came on too.


Ilang taon kana? ... Pontiac Grand Am
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 4.9626 seconds