Having problems with your 1989 Ford Crown Victoria ?

2003 mach1 mustang, no brake lights, no cruise control

\015 I have been having the same problem. I have a 2003 Mach1 mustang. I had two fuses changed as well as the brake light switch behind the brake pedal. Once the fuses were changed, my cruise control worked fine and I had brake lights. But not for long. I am back to square one again- no brake lights, no cruise control.\015 Posted / edited by AnonymousUser on : 26-10-2020

Answers :

Check the fuses, if they are blown, make sure they are the right size. If not, do not use bigger fuses than the circuit is supposed to have. If they are too small, use the correct size. If they are, do you have any extra equipment using the same circuit? Like a stereo or GPS or an alarm system? Move them to a different circuit. Check the relays to see if they are defective. Check all the bulbs to make sure they are the right ones too. Make sure they are in the right way. Check grounding wires, make sure they have good connections.
Repair Help & Product Troubleshooting for 1989 Ford Crown Victoria

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0087 seconds