Having problems with your 1991 Chevrolet C1500 ?

I have a 90 chev 1/2ton the brake lamps are inop,i was towing a trailer and the turn and brake lamps became inop, checked fuses and found turnsignal fuse blown and the brake good,but the brake fuse was a 15amp and some one had installed a 30amp fuse, i replaced the turn signal fuse and the turn signals worked but still no brakes, so i checked the brake switch and found the connector and switch burnt, i replaced the switch and fixed the wiring at the switch still no brake lamps?

Posted / edited by AnonymousUser on : 23-07-2018

Answers :

Use a test light and see if there is power to the switch. Then depress the pedal and you should have power on both sides. If there is no power to the switch, check the harness from the fuse box to the switch. If it got that hot, it may have melted the wire covering in the harness. You can use a jumper wire to the power side of the switch and try the brake pedal. You can get an inline fused wire and connect to the power side wire and see if it blows the fuse. That will tell you if the feed in wire is grounded. If there is power at the switch and goes through when you press the pedal down, look at the harness under the truck, especially around connections. Hope this helps. Mike
Repair Help & Product Troubleshooting for 1991 Chevrolet C1500

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0095 seconds