Having problems with your 1992 Chevrolet S-10 Blazer ?

I have a 92 chevy s10 blazer 4x4 4.3 vortec W i just replaced the fuel pump and fuel filter.. it will start sometimes mainly after it sits overnight but when you drive it you can only drive for about 10 mins and it will chug the whole time and then shutoff... i was told it could be the fuel pump relay or the fuel pressure regulator and was wondering what to try first?

Posted / edited by AnonymousUser on : 12-11-2018

Answers :

I had this problem.I removed the fuel pressure regulator and it was full of carbon.Remove it very carefully as to not damage any seals.Remove as much carbon as you can and reinstall.This should solve your problem.
Sounds like you have a problem with your ignition module the module will run fine when cold....when it heats up to normal operation temp...then will start to give you problems i think this sounds like your problem.....good luck
Repair Help & Product Troubleshooting for 1992 Chevrolet S-10 Blazer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0056 seconds