Having problems with your 1992 Chevrolet Suburban ?

Suburban loses power when driven over 50mph, it CHUGS!!

\015 Everytime I go over 50mph the truck seems to lose power and "chugs" like its not getting gas or something. runs fine in town only have problem when getting on interstate! doesnt matter if gas is full or half since its done it both ways.\015 Posted / edited by AnonymousUser on : 06-07-2020

Answers :

Try the fuel filter on the inside of the frame rail on the drivers side , i had the same problem and it worked for me , takes about 30 mins and is worth trying before resorting to replacing more expensive components.
The second poster is right it may very well be the throttle position sensor. I had the same issue but it turned out to be an oxygen sensor that had been detecting a too rich fuel mixture in one of the cylinders and eventually failed. I would take the vehicle to a shop and have the codes read off the vehicle. In the US Autozone will do this for you for free and print out a list of codes found.Either way it should help pinpoint the issue a bit better.
Repair Help & Product Troubleshooting for 1992 Chevrolet Suburban

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0052 seconds