Having problems with your 1992 Ford Crown Victoria ?

Hi i have asked this question before or similar. i put a 1993 motor in my 1992 crown vic. the original burned to much oil. so now i have a 1993 motor in my 1992 crown vic.when the 93 motor was first started i had no pressure in the oil gauge in the instrument cluster. it read zero.so after putting a brand new oil pressure sensor in close to the oil filter it started working. but after driving it for a few days the oil pressure gauge was all over the place. never a steady pressure. so i put

Posted / edited by AnonymousUser on : 05-04-2021

Answers :

Whattyou should do is hook up a meter at the sensor to see if its as erratic as the gauge.. If you get a better steady signal I would suspect wiring or a bad gauge . You stated the mechanic had better results hooked strait into the motor wich means the problem is most likely not the sensor or the engine. You could try removing the sensor and with an air compressor try to back blow the passage and see if that helps. Its possible you could have a chunk of crude floating around.
Repair Help & Product Troubleshooting for 1992 Ford Crown Victoria

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0097 seconds