Having problems with your 1992 Lexus Sc 300 ?

1995 Lexus SC300 looses power as temp increases.

\015 I have a 1995 Lexus SC300, and when cold, the car will start and run fine until it reaches normal operating temp. The higher the temp gets, the worse the car runs. At normal operating temp it will run, but has no power and develops a miss. Gently applying throttle will bring RPMs up, but slowly once warm. Quickly applying throttle once warm will cause it to miss, and bog, and sometimes die.126K miles on the car, and there are no error codes or service engine lights showing.I've replaced the ECU and MAF, as well as fuel filter and o2 sensors. Never anything except 93 octane fuel, and synthetic oil.I'm suspecting a temp sensor, or possibly bad/clogged cats.\015 Posted / edited by AnonymousUser on : 16-07-2018

Answers :

Evil -mast I have the exact same problem, did you ever find a solution?
Could be clogged cats or may even be bad crank sensor.
Repair Help & Product Troubleshooting for 1992 Lexus Sc 300

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0084 seconds