Having problems with your 1993 Chevrolet S-10 Blazer ?

Fuel System Mystery

\015 I have a 1993 S10 Tahoe, 4.3L TBI. I recently pulled it out of storage. Replaced Battery, Fuel Pump Relay/ECM Fuses, Fuel Filter, cleaned Injectors. I am getting almost a seeping of fuel into the Throttle Body but not enough to keep the engine running for more than a few seconds. I am also not hearing the fuel pump pressure up on start up. My question is, could there be another fix besides the pain of replacing the fuel pump that I might have overlooked? Any help is appreciated.\015 Posted / edited by AnonymousUser on : 10-12-2018

Answers :

Check for fire to the pump.one wire should stay hot the whole time the switch is on this is fuel gauge and 1 should be hot for a few sec's after switch is turned on then stop this is pump if you have fire i recomend using an a/c delco pump it'll cost a little more but you won't be pulling the tank again i've learned the hard way using cheap fuel pumps it don't pay when you have to put 3 or 4 in before you get a good one.hope this helps
Must replace fuel pump ,,nothing will pull fuel threw the ome pump thats in the tank
Repair Help & Product Troubleshooting for 1993 Chevrolet S-10 Blazer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0082 seconds