Having problems with your 1993 Toyota Land Cruiser ?

Erratic idle upon startup 1993 Landcruiser

\015 When I start my landcruiser, it idles erratically sputters, and sometimes dies. After a minute or two, it seems to improve and smooth-out. Sometimes if I stop at a light, it will do it also. Does anyone know if a faulty O2 sensor could be the problem? I just ordered a fuel filter, as I have had a similar problem on another vehicle, and that was the issue. Any advice would help.\015 Posted / edited by AnonymousUser on : 08-08-2022

Answers :

You need to run a vacumn check, and you should find the problem. O2 sensor could be an issue but more than likely it is a vacumn issue. I had and issue with a 93 LC that did the same thing. Another thing to check would be the ECU, do you have a check engine light that comes on and off regularly? Check out the codes if this is the case, it may tell you that there is an issue with the ECU. If you had an issue with the fuel filter on a ford that does not apply to the LC. The LC was design for very rugged and limited maintenance use. 100k on the worst gas imaginable and no maitenance. Highly unlikely it is the fuel filter. Try a fuel additive or injector cleaner first before replacing filter if you are curious.
Repair Help & Product Troubleshooting for 1993 Toyota Land Cruiser

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0084 seconds