Having problems with your 1993 Toyota Pickup ?

1993 toyota p/u 3.0 idle problems

\015 I have a small miss just above idle when its warm and a intermitent problem \302\240that after i have driving for a while and then if i turn it of for 30 min or so when i start it back up it does not want to idle at all for for about 10 mile then it fine it runs strong and smooth while being driven \302\240i have changed plugs and plug wires rotor & cap\015 Posted / edited by AnonymousUser on : 18-06-2018

Answers :

Maybe ur intake is too dirty, remove the air inlet hose that comes from the air filter to the intake. Insert a finger in there and check to see if its black and oily, if so, clean ur intake with intake cleaner can. Also ur MASS AIR FLOW could be defective in which case ur CHECK ENGINE light would be lit in the dash console.
You can loosen the distributer hold down clamp. get a timing light run the engine and check your timing marks let the vehicle run for a while and check timing marks again if they changed it's because either you egr valve is sticking open or closed or you have a vaccum leak. look for holes in the vaccum lines on the intake. if you have a throttle body your Tps sensor is most likely defective and needs replacing. you can turn the distributor to make sure your timing is 6 degress before TDC then tighten clamp(this is only done on carburator or TBI fuel systems)..please rate this thanks
Repair Help & Product Troubleshooting for 1993 Toyota Pickup

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0047 seconds