Having problems with your 1993 Toyota Previa ?

Heaters were not heating up machanic replaced water pump + thermastate and timing belt as radiator wasnt heating up now the water is boiling nut has not oil in it the oil level light is flashing but has no water in it and car is over heating

Posted / edited by AnonymousUser on : 15-10-2018

Answers :

There is 2 bleeders one can be accessed by the front of vehicle, the other if you lift the driver seat, if you do any coolant related job you have to open this bleeders during refill.
I don't understand why the timing belt was replaced for a heater problem. Is the car running rough or missing badly? Have you actually checked the oil or just relying on the oil level light. Check the oil and look for signs of water in the oil. If the oil doesn't show signs of water, refill the radiator with antifreeze and bring the oil level up to the full mark. Run the engine until it gets hot. Turn the engine off and let it cool enough so that you can remove the radiator cap. If the radiator is empty again, there must be leak somewhere. If you can't find a leak then it may be going inside the engine. If that is the case then the engine should be running very rough. Let me know what you find.
Repair Help & Product Troubleshooting for 1993 Toyota Previa

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0086 seconds