Having problems with your 1995 Chevrolet C2500 ?

1997 chevy cheyenne c2500...i get a popping noise when i press the accelerator...help meeeeee please...197,000miles i frustrated

Posted / edited by AnonymousUser on : 20-09-2021

Answers :

Does it idle smooth or rough? Steady loping miss at idle? Loses power as rpm's increase? I'm a shadetree mechanic, and even though your engine is a vortec, it still uses these parts, so you may find this useful.
\015\012
\015\012Make sure your plug wires are good, start it after dark, raise the hood, in darkness you should see tiny sparks jumping from the wires if they are bad.
\015\012
\015\012Most likely cause of my intake backfiring was #5 & #7 plug wires switched. Bad plug wires can also short onto each other and cause the wrong cylinder to fire while it's intake valve is still open, igniting back into the intake. 350 chevy firing order is 18436572. #5 & #7 are on the driver side, the closest to the back. #7 fires right after #5, by switching them I had caused #5 to fire too late / #7 too early hitting the accelerator causes the spark timing to advance, firing #7 while the intake valve was still closing, sending flame up into the raw fuel charged intake, causing the explosion or POP under the hood. The symptom I had was rough idle, stumbling / popping on acceleration, which got much worse as it warmed up.
\015\012
\015\012OTHER PROBLEMS TO LOOK AT:
\015\012replace fuel filter, and have a mechanic check the fuel pressure. He can tell you whether the pressure regulator or the fuel pump is bad. Low fuel pressure will lead to engine damage as you'll see below. It causes the combustion gases to run too hot, warping valves.
\015\012
\015\012I have a 95 c2500 with 350 Throttle body injection(not vortec), the problem I had was multiple. The timing chain was extremely worn out, causing erratic timing. The fuel pump was bad( causing loss of power as rpm increased)( letting that continue for 6 mos caused several intake and exhaust valves to overheat, warp and burn). The Throttle position sensor was bad, causing transmission shifting / slamming at odd rpms, and possibly contributing to the popping(backfiring up through the intake). The temp sensor on the intake was bad(cold temp fuel mixture control), and the oxygen sensor on the exhaust pipe had the wires pulled out of it(warm temp fuel mixture control). The spark control module also was bad(causes misfires). Later I also had 2 spark plug wires that were on the wrong plugs(the main cause of the intake backfiring). It is an old work truck, 190,000 miles, many parts/gallons of sweat later, now it runs strong. These motors are worth repairing, as long as the oil-pressure is good and the compression is still decent. I've had 3 vehicles before this one, same motor, great mileage, power and reliability. I've heard the vortecs are even better, as long as the oil gets changed regularly.
\015\012
\015\012 Start cheap. Try each item, if that is not it, go to the next( or spend a hundred or so on a full diagnostic by a well established mechanic(not a tire installer who just started his ASE studies. good engine diagnosis requires years of experience and teardowns to be able to determine the causes while running) :
\015\0121.) While engine is running in park, use plastic pliers(shock protection, be careful!!!) to remove and reconnect a plug wire at the coil. Listen for a change in the idle speed and smoothness. Move to the next if you hear a change, this means that that plug and wire are working properly(disconnecting them causes the motor to idle up, run rougher). If unplugging them doesn't cause a change: That wire or plug is likely bad. take both to an autoparts store to be tested. Replace the problem part, if that does not fix a miss, see #2 below.
\015\0122.) Do a cylinder compression test, to see if you have any valve issues. I bought a $40 compression tester kit. It takes about an hour, but it will tell you alot about the engines health. Mine had a range of 140-170 psi, except for #1( 0 psi, cracked and torched valve) and #7(120 psi, warped valve), I had to pull the intake and that head off for replacement valves(got lucky, cast iron head was not warped)
\015\0123.)pull, test(a mechanic can do this) and if necessary replace the throttle position sensor($23 part on tbi motors). This tells the computer how much gas pedal you are using. If it is bad, you fuel mixture will be erratic and can cause misfires, and your transmission may be shifting weird / hard.
\015\0124.) Replace the spark plugs with original AC Delco, use good wires, cap and rotor. Cheaper parts can have too much resitance to electric flow, causing poor running. I switched from autolite platinums--> to Delco = huge difference.
\015\0125.) If the timing chain is original. It is time, trust me. Mine had so much slop, I was amazed it had not jumped a tooth. This will cause poor power / erratic idle / possible backfiring if really advancing / retarding ignition. Unless you are a mechanic, this is not recommended for do it yourself. The upper radiator housing, fan, waterpump, timing cover and oil-pan have to be dropped and regasketed afterwards. Hours of fun.
\015\012
\015\012my truck sequence of events:
\015\012Bought spring '08, noticed poor power / slight miss, replaced plugs wires cap rotor, repaired rear brake line rust-out, new tires, mechanic replaced fuel filter, advised fuel pump was not putting out enough pressure, tried ignoring and drove till fall--> developed REALLY severe miss( no intake backfiring), barely made it home.
\015\012
\015\012Starting this spring: Compression test --> valve issues, removed all front engine components(alt, P.S.(pressed on pulley will need a puller kit to remove)), intake manifold and driverside cylinderhead(found a hole in #1 exhaust valve big enough to slide pencil through), had 4 valves replaced at machine shop, reassembled engine, dropped gastank, replaced fuelpump assembly and fuel-lines(rusted), replaced oxy sensor on exhaust manifold, started motor and set timing(while computer timing wire was disconnected under dashboard), ran rough / intake backfiring upon any acceleration, erratic timing, replaced timing chain = steady timing, still ran rough/backfire though, replaced temp sensor(no change), tested barometric pressure module = ok, replaced distributor(unnecessary), replaced throttle position sensor = ran a little better/still backfiring/ transmission problem fixed too, ran resistance check on wires with ohmmeter-->found #5 & #7 plug wires were switched, fixed that, ran great, replaced exaust system behind the converter, sounds great / runs great / lesson learned. If a mechanic advises a repair, get a second opinion... but don't ignore it, it creates bigger problems, like torched valves.
\015\012Good luck.
POSSIBLY COLLAPSED LIFTERS WORN CAM LOBES PULL VALVE COVER CHK FOR ADEQUETE MOVEMENT ON YOUR PUSHRODS
Repair Help & Product Troubleshooting for 1995 Chevrolet C2500

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0078 seconds