Having problems with your 1995 Chevrolet Camaro ?

Ok guys I need some help with my 95 3.4L Camaro, I did some recent work in the dash because the guy I bought this car trashed it and put in a cheap radio but did a poor job installing it. No Connectors just electrical tape kind of job if you know what I mean. I now have a power issue... I have a brand new battery and voltage and amps are good, when I turn the key to on dash lights for the display come on but nothing else, turn key to crank and every thing shuts off. I think it is a short or I lo

Posted / edited by AnonymousUser on : 17-12-2018

Answers :

You have either a bad connection at a major point, like the engine ground or the positive cable on the engine side, or you have dirty/loose/corroded battery terminals. One thing that can really be a hair puller is a cable, especially the ground cable, that looks good but is so full of corrosion that its resistance is crazy high. You voltage readings will be good with a meter. Heavy jumper cables can be really handy for quickly eliminating the main cables (or confirming a bad one.) Bypass your battery cables, one at a time and see if your problem is solved.
Repair Help & Product Troubleshooting for 1995 Chevrolet Camaro

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0107 seconds