Having problems with your 1995 Ford Probe ?

Dash lights and tail lights out. Fuse is good. Circuit relay makes noise when light switch is turned on to parking lights. Do I have a short or bad switch? Everything else is working. This is a 95 Ford Probe.

Posted / edited by AnonymousUser on : 10-12-2018

Answers :

You are not gonna believe this fix. Same year car, same problems. EXCEPT the final straw for me was when the dash guages started to smoke me out of the car.\015\012\015\012Pull the instrument cluster and identify the location of the ground circuit. Its all the flat ribbon style solder-wiring stuff. Also look for any obvious hot spots or discoloration. For me, the ground wire to this cluster was getting extremely hot because of the load the previous owner had put on the circuit. Had the car stereo fed from there. dont do it. \015\012Anyway, as the circuit gets used, the ground gets hot because it is no longer the right size required for the intended load. (remember the added car stereo load) Mine finally melted, so the fix was to replace the section of bad wiring with a jumper wire the same size or slightly larger and solder it into place.\015\012I would start here and at least rule out that possibility first.\015\012Good luck!
Repair Help & Product Troubleshooting for 1995 Ford Probe

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0094 seconds