Having problems with your 1995 Oldsmobile Cutlass Supreme ?

Fuel pump on '95 cutlass ciera

\015 I'm back again, The fuel pump on my 1995 cutlas ciera SL with 3.1 is\015\012not engaging when I try to crank it over. What could be causing this? There's\015\012an obvious solution staring me in the face, we recently pulled the\015\012engine and we cannot find where to plug in one last plug on the engine.\015\012the plug is black with two connections, blue rubber seal, the wires are\015\012yellow and brown. they appear to run along the back of the engine. Any\015\012suggestions?Any other solution involving the fuel pump will be appreciated, thanks!\015 Posted / edited by AnonymousUser on : 12-11-2018

Answers :

Check the control module make sure wires are all pluged in,also check crank sensor its in back of engine without this car wont start or get signal to fuelpump ,look close its kind of hidden must see from nder car.
Repair Help & Product Troubleshooting for 1995 Oldsmobile Cutlass Supreme

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0051 seconds