Having problems with your 1995 Plymouth Voyager ?

When I accelerate the engine sounds like a diesel. Something like a grinding noise. It also hesitates when starting off. I don't know if the 2 things are related. Gerald

Posted / edited by AnonymousUser on : 18-03-2019

Answers :

Put original factory plugs into your car.
\015\012change plug wires to original factory wires.
\015\012make sure there is no aftermarket performance chip in the computer/car ECU....
\015\012make sure you are using the right octane fuel.
\015\012make sure your air filter is not clogged change if necessary.
It sounds like you have no oil pressure. If it ran this way for long, the engine is shot. Does the oil pressure light come on when you turn on the key without starting? If yes, Disconnect oil pressure sending unit and short wire to ground. Does the light come on? If yes, Connect a mechanical oil pressure gage to the hole where the sending unit plugs in to. Do you have at least 30 PSI at hot idle? By now I'll betyou have a no answer. I need more info...
Repair Help & Product Troubleshooting for 1995 Plymouth Voyager

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0095 seconds