Having problems with your 1996 Chevrolet S-10 Pickup ?

At 55-60 mph I get a rumble under acceleration, it sounds like u joints but they were replaced without any change. this rumble goes away if I back off the throttle just a little by the way rpm is 2000 when this happens

Posted / edited by AnonymousUser on : 10-12-2018

Answers :

You may have a bad throttle postion sensor. With a data scanner it can be checked in a matter ir minutes or you can test the center wire for a staedy voltage sweep. Any dropouts would indicate to the PCM that you are releasing the pedal.
\015\012
\015\012Also you may have a ignition misfire or a vacuum leak on the intake. Data from a scanner will indicate what is happening. By not having this properly diagnosed with the correct tools could get costly since all anyone can do is guess otherwise. Once you eliminate the obvious options then one can go deeper. Not being able to see the truck and experiece the problem are you ready to just rhow more unneeded parts at this problem.
Repair Help & Product Troubleshooting for 1996 Chevrolet S-10 Pickup

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0090 seconds