Having problems with your 1997 Isuzu Rodeo ?

Fuel pump in my 97 rodeo works if i wire it to the battery,but does not work when i plug it in where it belongs.I've checked the fuses and they all look fine.

Posted / edited by AnonymousUser on : 10-12-2018

Answers :

Same thing happened to me on my 1996 isuzu rodeo. My fuel pump worked part of the time. I actually bought a new one, then tested the old one when I removed it. Like you, I hard-wired it to the battery. It turned out to still be good.
\015\012
\015\012It turned out to be a bad ground connection from the fuel pump. You can check it by --- 1) hooking the fuel pump back up where it belongs, 2) splicing a wire from the ground wire coming from the fuel pump and 3) grounding the wire (loosen a bolt head on the undercarriage, stick the stripped wire tip between a bolthead and undercarriage surface, then rachet the bolt head back tight. Then 4) just turn the ingnition key and see if the fuel pump engages and the engine starts.
\015\012
\015\012Good luck!
Hi i have the same problem with my 97 rodeo. it wont start but it turns over. and i just replaced the fuel pump and all i smell is gas when i try to start it. i am wondering what wire from the fuel pump did you run to the battery.
thanks,
Repair Help & Product Troubleshooting for 1997 Isuzu Rodeo

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0082 seconds