Having problems with your 1997 Jeep Wrangler ?

2.5 4 cyl engine Code P0171....Black Soot in the exahaust and water...Black soot on the plugs. I have replaced the catc and muffler, MAP sensor, coolant temp sensor, coil, plugs, wires, dist cap,cleaned all electrical contacts, both O2 sensors..... car starts quickly and runs good. Just gets 8 to 10 mpg. I plugged it into my laptop and the results from several runs on the comp are at the address below. I have more. Looked for leaks with spray nothing found....?? http://picasaweb.goo

Posted / edited by AnonymousUser on : 17-09-2018

Answers :

Black soot in water? You mean water in the tailpipe or black soot in the coolant in the radiator? Have you tested the manifold air temp sensor and the throttle position sensor? If they were OK, you may just have worn injectors that are allowing a bit too much fuel flow or a bad spray pattern. In the meantime, you could try replacing the plugs with a set that is one heat range hotter. If the plugs become slightly fouled, that can cause a snowball effect which makes the situation worse.
I HAVE THE SAME PROBLEM,IF YOU TAKE OUT THE THERMO.AND RUN IT WITHOUT IT THE PROBLEM GOES AWAY, WHY I DONT KNOW !!!
Repair Help & Product Troubleshooting for 1997 Jeep Wrangler

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0059 seconds