Having problems with your 1998 GMC Sierra ?

Rough accelleration from Idle

\015 When accellerating from stop, engine runs like a plug wire is off, not firing fully in order. I can prevent from happening with very light accellerating but forget hauling a trailer or pulling out in a hurry. This truck is a 93 z71 and it has 80,000 original miles and I have sufficient oil pressure and great temperature. The truck runs like a top until engine heats up and then it starts the periodic misfiring on the low end of the power band. The truck has plenty of power when it fires correctly. I took it to a local mechanic and he reset the timing and that helped but he said that he couldnt diagnose it until there was a problem present. I have no warning lights that come on or anything. At idle, it sound great, as long as you keep the oil pressure up above 20lbs it seems to run great. It's just on the low end. Please help\015 Posted / edited by AnonymousUser on : 22-02-2021

Answers :

William, the icm is on the intake, and the cam sensor is in the bottom of the distributor, at least on my 4.3 anyway, just a thought.
Try changing the ignition control module in the bottom of the distributor this controls the firing of the plugs and usually when they get hot is when they start acting up. not very expensive plus you can take yours off and have it tested at a parts store.
Repair Help & Product Troubleshooting for 1998 GMC Sierra

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0083 seconds