Having problems with your 1998 Mazda Protege ?

The altinator belt on my 1995 mazda protege keeps breaking how do i fix that?

\015 This is the second time i have had to replace this belt in two weeks, i thought we fixed it because it quit squealing and i was driving it home to day and it snapped off again\015 Posted / edited by AnonymousUser on : 25-10-2021

Answers :

Spin your pulleys by hand and make sure they spin freely and smoothly. If any pulley fails to do so replace it. When installing belt make sure tha tha belt sits in the center of the pulley. If off by one groove the belt will fail. Make sure there are no oils or coolant on the belt and or pulleys and any foreign objects on the pulleys grooves must be removed and or cleaned. Good luck!
Based off of the info you gave me it could be a few things.
is belt the right size? belt size may seem right but it can happen due to the slightest size difference.

what did the broken belt look like? were the grooves all around worn out quickly if belt doesnt have grooves was the belt seemingly worn faster than it should all the way around its circumferance? this would indicate that the belt is not tight enough OR wrong size Or not tightened properly.
Were they worn down in one spot more where it also broke? if you have a pully in the belt system that is hanging or not moving at all this is the culprit. this also means you have other issues depending on what that pulley is attached too. good luck
Repair Help & Product Troubleshooting for 1998 Mazda Protege

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0089 seconds