Having problems with your 1999 Chevrolet Cavalier ?

New alternator didn't charge battery. (2VDC

\015 3 days after new alternator install, - alt wouldn't charge battery. (2VDC reading at Batt. - 13.9VDC from alt.) After boosting, I ran the car for 30km or so, then out of necessity, turned high beams on while driving. It didn't like that, and the vehicle shut down. While rolling, shifted to neutral, and tried ignition. Started!., and now alt charges properly. What the heck?\015 Posted / edited by AnonymousUser on : 15-07-2019

Answers :

As the car re-started, the battery is not flat.
\015\012The voltages measured indicate a problem with either the power or ground connection in the circuit between the alternator and the battery.
\015\012
\015\012You likely have a intermittent / poor ground connection somewhere in the power system.
\015\012Check battery terminals are clean and firmly attached.
\015\012Check battery cable and alternator ground connections are intact and in good order.
Repair Help & Product Troubleshooting for 1999 Chevrolet Cavalier

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0075 seconds