Having problems with your 1999 Chrysler 300M ?

My 99' 300m has a problem. after i drive it for a

\015 My 99' 300m has a problem. after i drive it for a while,( and the temperature gauge gets slightly above the half way mark,) if i turn it off it won't start again unless i let it sit for about 20 minutes. or if it does start, it just boggs and sputters! i have the V6 3.5. I had a "certified" mechanic tell me these and also the 2.7 engines are junk and defective but chrysler won't issue a recall. ok... need help! If its simple i'll fix it. Love my car. btu if not i'm getting rid of it! Don't know if teperature gauge has anything to do with it? thats how i know its gonna stall if its turned off.\015 Posted / edited by AnonymousUser on : 20-09-2021

Answers :

It may help to try to install a lower temperature thermostat than the one currently installed. This is a cheap place to start $15.00 or less for the part.
Repair Help & Product Troubleshooting for 1999 Chrysler 300M

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0087 seconds