Having problems with your 1999 Dodge Avenger ?

Transmission codes: codes: p0734 gear 4 ratio incorrect p0731 gear 1 ratio incorrect p0715 input/turbine speed sensor a circuit malfunction p0733 gear 3 ratio incorrect p0700 trans control system malfunction how would i fix these problems on a 1999 dodge avenger v6?

Posted / edited by AnonymousUser on : 10-12-2018

Answers :

I WOULD TRY REPLACING THE INPUT SPEED SENSOR..A DEFECTIVE SPEED SENSOR CAN CAUSE ALL OF THESE FAULTS..IT IS LOCATED IN FRONT OF TRANS ABOVE SOLENOID PACK..IT IS THE ONE CLOSEST TO THE ENGINE..IT SCREWS INTO TO TRANSMISSION..A 1 INCH SOCKET FITS IT..ALSO CHECK WIRING TO BOTH SPEED SENSORS..A SENSOR IS ABOUT 35 BUCKS,AVAILABLE AT YOUR LOCAL DODGE DEALER..GET A NEW ONE AND YOU'LL SEE WHAT IT LOOKS LIKE..FAIRLY COMMON PROBLEM..HAVE REPLACED LOTS OF THEM
I need to know how to stop the speed indicator from jumping all over the place on my 95 dodge intrepid i have replaced to two speed sensors,but the speed indicator still jump all over
Repair Help & Product Troubleshooting for 1999 Dodge Avenger

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0094 seconds