Having problems with your 1999 Ford Escort ?

99 ford escort se gets no power and stutters.

\015 When i start my car it will start fine. but when i press the gas to go must of the time it stutters and doesnt want to go. I can push the gas pedal down all the way and go nowhere sometimes. Also if i am driving on the interstate when i get up to about 50 to 55 mph the car will **** pretty hard sometimes. I have replaced the fuel filter and that did not help. Any information on what it could be would be helpful.\015\012\015 Posted / edited by AnonymousUser on : 30-11-2020

Answers :

When was the last time the timing belt was replaced on it? The cam timing may be retarded back from belt stretch creating this problem. Another thing to check out is if your catalytic converter may be partially plugged up.
Try looking into a vacuum leak. I had a 99 Escort ZX2 that had a bad PCV valve hose and it was doing the same thing. Replaced hose for $20 and ran perfect.
Repair Help & Product Troubleshooting for 1999 Ford Escort

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0097 seconds