Having problems with your 1999 Ford Escort ?

Changed timing belt on my 99 ford escort zx2 car no

\015 Changed timing belt on my 99 ford escort zx2 car started and ran started getting rough now will not start not fire at spark plugs changed coil still no fire stuck plz help\015 Posted / edited by AnonymousUser on : 19-11-2018

Answers :

If you have a no spark scenario i would check your crank sensor located at the top left side of the harmonic balance pulley.the crankshaft (about 11'oclock) a 2 wire plug with a sensor on it check to see if it is damaged or unsecured. this sensor can cause no spark if not working correctly. This sensor is based of frequency not voltage testing is difficult, just make sure that there isnt too muck air gap. and that it is secured.Lastly may want to check timing possible that the belt has jumped some teeth and she has fallen out of timing. maybe a bad tensioner The coil will adapt i think up to 10 degree, ****** or advance. Good luck
Crankshaft position sensor may need replaced, or the timing belt was not put on crrectly.
Repair Help & Product Troubleshooting for 1999 Ford Escort

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0052 seconds