Having problems with your 1999 Ford Expedition ?

My 1999 Expedition shakes and runs rough. Recently a check engine light came on followed by the problem. I had it checked at autozone where I was told the spark plugs and wires needed changing. I had these changed and it still ran the same. I had a former mechanic check the check engine light again and he said it was the coil. We changed both. It is still running the same. Any suggestions?

Posted / edited by AnonymousUser on : 24-06-2019

Answers :

I had somewhat of the same problem for a while. Engine light was on and during idle the rpm would drop real quick and then spike, and start surging(shaking and stalls at stop/red lights). I found the problem was that one of my vacuum hoses had collapsed causing this problem. You might want to find out what the code says if you don't know already. If it comes up with a lean code then this could be helpful.
You need to remember that Autozone is good for the checking of codes for free,But they are not mechanics!,
there is no code that says replace the plugs and wires,
and there is no code that says replace any coil
Repair Help & Product Troubleshooting for 1999 Ford Expedition

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0050 seconds