Having problems with your 1999 Ford Explorer ?

My 1999 ford explorer makes a squealing noise when I start it up until I push on gas or proceed to move...it will also occassionally make this squealing noise as I am driving..any Idea what this could

\015 Recent repairs include: power steering well replaced, alternator belt replaced, all cvs boots replaced, u joint replaced. weird thing is my check engine light has been on for years now and now that a problem arises it goes off and has stayed off so far, this puzzles me because the codes that were listed were repaired and it was reset by mechanic, but would come back on within several days. Any help in this matter would be appreciiated..thanks\015 Posted / edited by AnonymousUser on : 21-09-2020

Answers :

The squealing noise you describe is usually from a slipping belt. The belt tensioner may be faulty and not keeping the belt tight enough, the alternator is charging and putting a load on the belt when you first start the engine. If the belt squeaked constantly I would say the belt is glazed.
Repair Help & Product Troubleshooting for 1999 Ford Explorer

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0093 seconds