Having problems with your 1999 Ford Taurus ?

OIL PUMP PROBLEMS

\015 We put a new oil pump in the car, and it still wont pump oil. We primed it with grease before we put it in, and the rod from the oil pump to up in the motor seemed fine. We put the oil pump in oil and checked it out before we put it in the car and it pumped fine, so can you tell me what else to do. We have done put it back togeather, so can you help?\015 Posted / edited by AnonymousUser on : 15-07-2019

Answers :

The oil pump is not electronic it is gear drivin . either the gear is bad or the installation was done incorrect. my advice is to start over and sure the rod is seated correctly . you should be able to put the rod in and not be able to spin it. if it spins that means either the gear is completely bad or the rod needs replacing or both. in order to replace the gear you have to remove the timing chain. in your vehicle if you have a distributor and not coil packs you have to remove the distributor and look at the bott of the shaft to see if it is worn out. hope this helps........please rate this.
Repair Help & Product Troubleshooting for 1999 Ford Taurus

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0050 seconds