Having problems with your 1999 GMC Suburban ?

1999 yukon denali no ac or heat blowing

\015 A few days ago my girlfriend started having this problem, The ac/heat will not blow/ from either the front or the rear zones. I replaced the blower motor relay and it did nothing. the blower fuse under the hood looks good. after it stopped working the first day it came back on a fdew minutes later for about 5 seconds. anyone have any idead?\015 Posted / edited by AnonymousUser on : 06-04-2020

Answers :

Chk the fan speed resistors mounted in the fan housing. You should be able to see the wires going into the box with 2 screws holding the resistors in place. Good Luck.
There is a blower resistor that can fail. it's behind the glove box by the blower motor. there is also an auxiliary blower motor resistor in the back. if i had to guess i would check the front one first. you have to open the glove box then reach in the back and pull it all the way out. then you have to remove what gm calls the plenum tray. then there is an electrical connection that you have to unplug and then take the mounting screws out and then put it all back together. it is a good practice for safety to disconnect the battery negative terminal while you do this. hope that helps
Repair Help & Product Troubleshooting for 1999 GMC Suburban

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0085 seconds