Having problems with your 1999 GMC Suburban ?

1999 Chevy Suburban K1500 Transmission problems

\015 In June I took my truck to get the tranny fixed because it would shake when I would take off and it didn't want to go backwards without alot of loud noise. The shop I went to rebuilt the tranny, little things just didn't seam right like rolling down the driveway backwards it would whine and sometimes when I would start the truck it would make a loud bang and shake but it would start everytime. I haven't driven it much untill the last 2 weeks when I put my other burb up for the winter. Now I'm driving this one and yesterday it started making a loud knocking noise in the front of the bell housing, so today I take it to the shop and they say that its the flywheel. Do you think that it is something that just went bad in the last 700 miles that I put on or it was something that they did when they rebuilt my tranny. \015\012\015\012Thank you for any help!!\015 Posted / edited by AnonymousUser on : 10-12-2018

Answers :

Possible that it was damaged before and was over looked, or the transmission was not installed flush against the back of the engine block before the torque converter bolts were attached to the flexplate causing an abnormal wear and excessive stress causing it to break.
Repair Help & Product Troubleshooting for 1999 GMC Suburban

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0056 seconds