Having problems with your 1999 Mercury Grand Marquis ?

Coolant guage only registers about 1/4 of range when warm. think maybe coolant sensor but want to make sure not indicative of larger issue...buddy is looking at '98 marquis and has limited budget

Posted / edited by AnonymousUser on : 06-04-2020

Answers :

The coolant sensor is a grate start. it seams to be that every thing is working just alot of risistance from point A to point B.
\015\012
\015\012to find it locate the sensor by finding 2 small wires leading to the side of the engine. make sure the car is off and cold befor removing. it will leak radiator fluid so have a bucket ready. remove the sensor and clean it off(8mm socket should work). note that you have to put pipe selant on the threads befor re installing. also inspect the wires for corosion. if they are corored just replace the wires. After everything is back together start the car and inspect your work make sure it's not leaking. if the problem continues receck the wires but all the way the ECM/computer give them a wiggle, this may re conect a lose wire. don't pull just push softly and wiggly up and down.
Coolant sensor or thermostat not to much to get the parts and repair yourself. I dont see a big problem
Repair Help & Product Troubleshooting for 1999 Mercury Grand Marquis

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0053 seconds