Having problems with your 1999 Mercury Villager ?

Cruise control stopped working 1999 mercury Villager the RPM gage has never worked since I got the vehicle several years ago, and today the cruise control stopped working. The light comes one and stays green until I drop to much speed.

Posted / edited by AnonymousUser on : 12-11-2018

Answers :

Sounds like the cruise control cable is broken take it to a mechanic
After posting the question, a sim question was brought up by some one else, and that directed me to look at the cruise control cable (that I did not know what it was before this) the cable was not broke but the bracket that it bolts onto, it had came lose from this bracket, thus when the cruise control would try to kick in it could not put the tension on the cable like it needed, thus would not work.

I put it back on the bracket and tightened down the bolts (a little lock tight as well) and it now works.

If it was not for advise from this site, I would still be guessing.
Repair Help & Product Troubleshooting for 1999 Mercury Villager

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0082 seconds