Having problems with your 1999 Oldsmobile Alero ?

1999 Alero: I replace the head gaskets thermostat water pump n...

\015 I replace the head gaskets thermostat water pump n hose why is my car still running hot\015 Posted / edited by AnonymousUser on : 15-10-2018

Answers :

OK you have done the engine side of things. If you have an electric radiator cooling fan make sure it comes on when radiator is hot, if not the fan motor is caned or the thermostat switch is faulty. Sometimes the fan motor is supplied by a fused/relayed circuit in which case these items will also need to be checked. \015\012Check that not only does the top hose from the engine to radiator get hot but that the bottom one does too. If not this would indicate a blockage perhaps in the radiator core due to sludge. If full of sludge give both ends a flush out with a high pressure hose. Like wise do the same with the bottom hose back to the pump. If the water is circulating and the radiator fan is working then the normal cooling system is working as it should.\015\012f the engine is running hot one last thing is to find the EGR valve and check that it is opening as it should. If not the combustion temperatures go very high. One indicator of a hot engine is blue/glazed spark plugs so take one out and check it for signs of hot running. If hot then look to clean the EGR valve and associated exhaust gas feeder pipe with frayed cable, cloth and and carb cleaner spray.
Repair Help & Product Troubleshooting for 1999 Oldsmobile Alero

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0090 seconds