Having problems with your 1999 Oldsmobile Bravada ?

Hi, This morning I tried to start my 2001 Lexus es300-nothing, no cranking. A few of the dash lights flashed on briefly. I left the car alone for a couple of hours, went out and tried to figure it out. The lights were brighter and when I put the car into neutral, all of the dash lights came on. I put the car back into park and it started immediately. I let the car run for 45 minutes, turned it off and it instantly restarted. I did this several times. About 3 hours later, I tried to start the car

Posted / edited by AnonymousUser on : 19-02-2018

Answers :

Ok this should work, I think that you disconnected the battery terminals when you clean the corrosion correct? If you did then TOYOTA/LEXUS will tend to blow the BATTERY MAIN FUSE. Its located in main fuse box in the hood Its A big Black fuse check the view screen on the top of fuse and see if it broken/damaged this should be your problem. Replace and vehicle should start. Good Luck and contact if you need more help. Thanks for using FIX YA
First of all get some baking soda and water and clean off the battery cables and then the next thing when was the last time the drive belt was changed and depending on the miles if over 100,000 or more have the alternator tested
Repair Help & Product Troubleshooting for 1999 Oldsmobile Bravada

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0051 seconds