Having problems with your 1999 Subaru Impreza ?

1.When first starting wont move until fully warmed-up. When in gear it will putter when gassed let off returns to idle 2.Transmission sometimes wont engage. Put fluid and stopleak

Posted / edited by AnonymousUser on : 20-08-2018

Answers :

These problems are all because you have vacuum leaks in your transmission (probably). You are, unfortunately, going to have to take it in and have it serviced. I highly recommend using a transmission specialist and not a general mechanic. Also, there is NOTHING that comes in a bottle that will fix ANY engine or transmission issues. They're just taking advantage of people who aren't mechanically inclined and are willing to try anything. These products only add foreign material to your system and help gunk up the works. Don't use additives of any kind. Not stopleak, not octane booster, not water remover, not oil boosters. None of it.
Repair Help & Product Troubleshooting for 1999 Subaru Impreza

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0053 seconds