Having problems with your 2000 Plymouth Voyager ?

All of a sudden I started my van and the speedometer doesn't work and the check engine light comes on

Posted / edited by AnonymousUser on : 19-11-2018

Answers :

You can try to reset the cluster by perform an instrument calibration. If I remember correctly, push the trip odometer and reset buttons in until the gauges react. The cal takes about 10 seconds. If it's still bad after that but, the speedo moves during the cal, it's a good bet the speedo is good and the problem lies elsewhere.

If that doesn't help try removing the IOD fuse for a couple minutes. It's in the fuse/relay panel next to the battery. This resets the body control module (BCM) which controls most of the electronics in the van.

Still dead? It's either the cluster, BCM, or vehicle speed sensor (VSS) on the tranny, or wiring. Since you're not complaining of shifting problems I would think it's likely not the VSS. If you go for the cluster, check the connectors contacts and solder joints closely. They are notorious for being subpar. An indication of this would be the speedo coming to life after you smack the top of the dash (common technique).

OBTW The dealer can determine the problem in minutes using a scanner.
Repair Help & Product Troubleshooting for 2000 Plymouth Voyager

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0087 seconds