Having problems with your 2001 Oldsmobile Silhouette ?

Tempeture gauge my tempeture gauge stays below the cool mark but does not rise to warm or hot but blows out warm an hot air could the tempeture sensor have gone bad .

Posted / edited by AnonymousUser on : 12-11-2018

Answers :

After running the vehicle for a while check the temperature of the fluid in your reservoir tank. If it is cooler than the temp in the radiator(this should be extremely hot and the res tank should only be warm) then it is most likely your thermostat sticking shut. It's a pain to change but luckily the part only costs around $10.
Just fixed this problem myself.
\015\012
\015\012In addition to the above description, my service engine light came on about a week after the gauge stopped working.
\015\012
\015\012Took it to Auto Zone and had them do an error code scan, this is a free service of AutoZone.
\015\012
\015\012Code P0126 - Coolant Temp is always low.
\015\012
\015\0123 possible causes
\015\012
\015\0121) Check Engione Coolant
\015\0122) Thermostat defective
\015\0123) ECT sensor defective.
\015\012
\015\012
\015\012I added approx two pints of coolant. The Check Engine Soon light went out and the temp gauge started working again.
\015\012
\015\012
Repair Help & Product Troubleshooting for 2001 Oldsmobile Silhouette

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0051 seconds