Having problems with your 2002 Chevrolet S-10 ?

S-10 Sometimes Starts, Mechanic Can't Find Problem

\015 Having a weird problem with our 2002 Chevy s-10. Here are the facts thus far....starts sometimes (if it starts there are no problems and no weird noises or electrical issues). When it doesn't start, all the electrical works without a problem, but the ignition is completely dead, no attempted turn over, no sound whatsoever. However, I did notice a buzzing sound coming from under the chaise on the driver side when I was trying to start it. The buzz lasted about 3 seconds and then turned off. Truck still didn't start though. The problem is, that the problem is intermittent, so every time we've taken it to the mechanic (even had it towed once), it started up just fine for them. Any ideas?\015 Posted / edited by AnonymousUser on : 10-12-2018

Answers :

Yep, heres one. Start with pulling the crank fuse. The fuse is probably good, but you have a corrosion/contact issue. Putting it back will solve this issue. I would do all of them, as one will do it, more are sure to follow. Also do they relays. Next would be checking wires. Most times wires will loose connection at the plug, sometimes they will break right at the plug.
Repair Help & Product Troubleshooting for 2002 Chevrolet S-10

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0085 seconds