Having problems with your 2002 Mitsubishi Montero ?

Still Pegged at Max Hot even with new Tstat

\015 The check engine light (actually Service Engine Soon) is NOT on. Interestingly enough, while we were running the water pump test you suggested, the temp continued to climb as we were adding more fluid (which I am assuming means the pump was working since the fluid level continued to drop), but when we turned the car off and pulled the drain valve from the radiator and drained off about 2-3 cups, the temp gauge went down to normal operating temp. I climbed back up again when we turned the car back on. Any idea what that indicates???\015 Posted / edited by AnonymousUser on : 22-04-2019

Answers :

Glad to hear the water pump is working!
\015\012
\015\012Have you checked the seal of the radiator cap?
\015\012
\015\012Another possibilty I forgot to mention is the fan clutch. This is what engages and disengages the fan. If it is working you should hear a 'click' sound as it engages and disengages.
\015\012
\015\012c39c3b5.jpg\015\012
Repair Help & Product Troubleshooting for 2002 Mitsubishi Montero

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0097 seconds