Having problems with your 2002 Oldsmobile Alero ?

2002 Oldsmobile Alero. My service VEHICLE (not engine), TRAC OFF and ABS lights all come on when i drive my vehicle. My uncle has hooked it up to a scanner and it doesnt give a code(i'm guessing because the service ENGINE light is not on) . I have replaced the brakes and rotors , it still doesn't stop them from coming on. Please help!

Posted / edited by AnonymousUser on : 16-07-2018

Answers :

This is most likely being caused by an intermittent connection to one of the abs sensors which are part of the wheel bearing hub assemblies.You would need a scanner capable of reading abs codes in order to determine which wheel is causing the issue. This is a common problem usually it is one of the front hub assemblies not always but a majority of the time.
It could be the ABS system. Like the computers and electronics, not the braking components. Also, on a lot of cars, when you have that light and fix the items that are causing it, the light will stay on. Sometimes you can just disconnect the battery for 20 min to reset the ECU but that doesnt work on all cars. It may need to have the system cleared with a code reader. Did you take it to NAPA or somewhere to have the codes read, that will tell you exactly whats wrong with it. Otherwise you end up spending tons of money replaceing items that dont need to be.
Repair Help & Product Troubleshooting for 2002 Oldsmobile Alero

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0089 seconds