Having problems with your 2003 Audi A6 ?

Prob's with my Audi A6 2003 Auto 3.0 V6 (gearbox)

\015 Hi Having prob's with my Audi A6 2003 Auto 3.0 V6, the gear selector display(PRND) sometimes flashes or has no display. when it is flashing & you move the gear stick to PRND or select the tip tron gears 1-6 the display just keeps flashing. in this state the car drives forward normally the only problem is when i select reverse, sometimes it reveres ok sometimes it doesn't i.e you can feel the gear engage but when you hit the gas the car doesn't move. I've had a mate diag it for me and I get the code/messages (17093 transmission range sensor, F125 Not a plausible signal P0706).So my question is do you think I need a new gearbox?? thks Marco\015 Posted / edited by AnonymousUser on : 10-12-2018

Answers :

Doubt it as the fault suggests you need to look into the range sensor. If similar to Renault there is a switch on the gearbox that senses where the select lever is (at the gearbox end). If the display is wrong then the sensor needs looking at and either it will need to be adjusted into a set position by moving it, or perhaps the connector to it or wiring to/from it have a fault.
Did it fix the problem with new TCM
Repair Help & Product Troubleshooting for 2003 Audi A6

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0090 seconds