Having problems with your 2003 Ford Expedition ?

Ok..here's the problem..for the past month when I put the AC on, regardless of it being on auto or just me choosing the fan speed, it will shift from the front vents to defrost vents by itself. it will continue to do this the whole time the ac is on.

Posted / edited by AnonymousUser on : 20-08-2018

Answers :

Hi.

It is either a vaccum leak or a defective PVHS (Vacumm Hub Solenoid). First test the vacuum using a gauge (Lisle\015\012 20300) in vacuum lines while heating the lines or spraying the lines with spray lube (Multi-Purpose lube).

After ensuring that there is no leak, go for the solenoid. The solenoid can be tested reading Ohms at its contacts and ensuring that there is continuity.

Vacuum leaks are most common cause for this problem.

See also this forum.
The logic of the door that controls defrost or vent is messed up either by a loose vacuum hose to a vacuum motor, or a bad vacuum motor.
Repair Help & Product Troubleshooting for 2003 Ford Expedition

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0093 seconds