Having problems with your 2003 Ford Focus ?

Takes 10 minutes for car to drive forward after placed in drive .No problem in reverse .

Posted / edited by AnonymousUser on : 08-08-2022

Answers :

I have had this problem in the past and it proved to be a clogged transmission filter. You can do this yourself (its a messy job since there are no drain plugs in the pan) or take it to your local tranny shop. Good luck.
First, check your Trans fluid level. The next 3 possibilities are the shifter, shift cable and the valve body.
\015\012
\015\012Have a helper shift the car while you watch the cable end move on the Trans. Or disconnect the cable at the Trans and shift it without the engine running. The action should be smooth and immediate. It is possible for the cable to bind and then release.
\015\012
\015\012If the shifter is binding it will also affect the cable movement. You can try to spray WD40 or a similar moisture fighting lubricate on the cable and inside the shifter mechanism.
\015\012
\015\012If this does not help you are going to need to look at the Trans. About the only thing cheap you can try is a Trans filter change and new Trans fluid. The valve body is the most accessible part of the Trans.
\015\012
\015\012Hopefully your problems will be simple and the shift cable will take care of it. Good Luck on this.
Repair Help & Product Troubleshooting for 2003 Ford Focus

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Suggested Questions/Answers :

Loading ...

  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || carrestorationshop.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0052 seconds